Announcement

Collapse
No announcement yet.

Search Result

Collapse
37 results in 0.0174 seconds.
Keywords
Members
Tags
  •  

  • arvidj
    replied to Dynasty 350 ... dead
    My comments in bold within the quote.

    Now maybe the work, health and family issues that prevented me from using the machine are behind me and I can actually use it!!...
    See more | Go to post

    Leave a comment:


  • arvidj
    replied to Dynasty 350 ... dead
    In the end this has turned into a perfect example of why you might want to purchase your equipment from a LWS and an well established manufacturer .

    Going against me was "out of warranty", "machine is 5 years old", "the machine was dead".

    The...
    See more | Go to post

    Leave a comment:


  • arvidj
    replied to Dynasty 350 ... dead
    The regional rep just called and thinks he may be able to work something out. He is going to do some research and get back to me.

    Maybe I an not "On my own".
    See more | Go to post

    Leave a comment:


  • arvidj
    replied to Dynasty 350 ... dead
    Cruizer,

    Thanks for all your support and insight. I do appreciate it.

    The Tech was in the same Catch-22 I was in. He could not determine how low the hours were because the machine was dead. He only had 'my word for the low hours' and that may not have been enough for him....
    See more | Go to post

    Leave a comment:


  • arvidj
    replied to Dynasty 350 ... dead
    To save others who might be tempted to call Miller looking for some type of good will warranty extensions, don't bother.

    They will refer you to the Miller District Rep as "the only person who might be able to resolve this type of issue". They will give you the name and phone...
    See more | Go to post
    Last edited by arvidj; 01-16-2015, 08:15 AM.

    Leave a comment:


  • arvidj
    replied to Dynasty 350 ... dead
    Now that it has power I can ask it for the hours and starts.

    Hours ... 3 hours and 52 minutes.
    Cycles ... 482

    I do not think this is an excessive amount of time or cycles but someone may be able to offer alternative thoughts.

    Anyway, at $2365 per hour [original...
    See more | Go to post

    Leave a comment:


  • arvidj
    replied to Dynasty 350 ... dead
    Well the LWS called today and have it running. They say it was a little under $2200 to repair. They say they had to replace the main power board [PS1 from memory], both modules and both of the main capacitors.

    Now that it is running I'll be able to get the hours and starts information from...
    See more | Go to post
    Last edited by arvidj; 01-14-2015, 08:20 PM.

    Leave a comment:


  • arvidj
    replied to Dynasty 350 ... dead
    I dropped the welder off at the LWS today for repair.

    The assumption is made that large amounts of cash will be required to retrieve it sometime in January.
    See more | Go to post

    Leave a comment:


  • arvidj
    replied to Dynasty 350 ... dead
    The garage is a minimum of 45 F. all the time. It was 45 when I first tried it and since I have been working on the welder the temperature has been 68 F.



    No pop or crackle or signs of distress. If I turn it on and then off I measure a decaying voltage [35 volts and decreasing...
    See more | Go to post

    Leave a comment:


  • arvidj
    replied to Dynasty 350 ... dead
    As a follow on question ...

    Assuming I can track this down to a specific board ... where does one go to get reasonably priced replacement parts? Preferably refurbished but if not then new.

    Thanks,
    Arvid
    See more | Go to post

    Leave a comment:


  • arvidj
    replied to Dynasty 350 ... dead
    I unplugged, sprayed contact cleaner into, and then replugged every molex I could find on all the boards and still nothing.

    I again measured the voltage at terminal A1 and A2 on PC1 - POWER MODULE and it was 245. So power makes it to the board and that is where it ends. No display, nothing...
    See more | Go to post
    Last edited by arvidj; 12-16-2014, 07:30 AM.

    Leave a comment:


  • arvidj
    replied to Dynasty 350 ... dead
    The three external wires coming from the plug to the switch are indeed color coded and attached in that order. All three of the wires from the switch to the side input/output board [i.e. the internal wires] are black. I am assuming that the connections move "across" the back of the switch...
    See more | Go to post

    Leave a comment:


  • arvidj
    replied to Dynasty 350 ... dead
    I don't understand this statement.

    With the switch off, when I measure the voltage between the black and the white wires on the back of the switch I get the expected 240 volts. When I measure the voltage on the terminals on the opposite side of the switch [all three have black wires so...
    See more | Go to post

    Leave a comment:


  • arvidj
    replied to Dynasty 350 ... dead
    Thanks for making a guess but I do not think lightning is the issue.

    The switch on the back was off which isolates both hot leads from the breaker box. The neutral is not connected at the plug, which leaves only the ground physically connected to the breaker box.

    I made...
    See more | Go to post

    Leave a comment:


  • arvidj
    started a topic Dynasty 350 ... dead

    Dynasty 350 ... dead

    Years ago I purchased a new Dynasty 350, SN# LJ030801L. I used it a couple of times and then life intervened and it has been sitting in my heated Minnesota garage, plugged in but turned off, for at least two, very likely more, years.

    Yesterday I actually wanted to use it so I turned it...
    See more | Go to post
Working...
X