Announcement

Collapse
No announcement yet.

Search Result

Collapse
4 results in 0.0052 seconds.
Keywords
Members
Tags
  •  

  • surferpat
    replied to Wire Feed Problems, MIG, XP135
    Replaced Copper Tip

    I think I may have fixed my wire feed problem. Several people on this website have suggested either replacing the copper tip on the gun, or using a standard cutting torch tip cleaner to open up the passageway in the copper tip. Well, I had been using the tip cleaner...
    See more | Go to post
    Last edited by surferpat; 12-14-2006, 01:49 PM.

    Leave a comment:


  • surferpat
    replied to Storing stick electrodes
    Heating Rod

    I do not know everthing there is to know about storing welding rods, but here is something that has worked pretty well for me. Here in East Texas, we have competing weather patterns. Cold dry air from the north, and warm moist air from the Gulf of Mexico. In my shop, I...
    See more | Go to post

    Leave a comment:


  • surferpat
    replied to New guy here.
    New MIG

    I bought my Miller XP135, 120 volt MIG about 4 years ago. I had been doing mostly stick welding, off & on for 12 - 15 years. I had no MIG experinence at all when I bought it. The learning curve is very, very short. You could teach your grandmother to MIG weld. There are...
    See more | Go to post

    Leave a comment:


  • surferpat
    started a topic Wire Feed Problems, MIG, XP135

    Wire Feed Problems, MIG, XP135

    I am having a problem with my Miller MIG XP135. It is just a small 120 volt machine. I have had it about 4 years now, and have put about 4 to 5 spools of wire though it. It does not feed the wire though the torch wand worth a hoot. In the past, when I had feed problems, I took apart the torch wand,...
    See more | Go to post
    Last edited by surferpat; 11-28-2006, 06:44 AM.
Working...
X