Announcement

Collapse
No announcement yet.

180sd problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • wb5jhy
    replied
    uh....Miller?

    You might call your local Miller rep and order through them. If still under warranty you could call Miller support first. They sent me a part before when mine was under warranty. They gave me the option to install it myself or take it in to a service center. I had the part in my hands in two days. Excellent service.

    Leave a comment:


  • jmercado
    replied
    Can someone tell were I can buy the transducer.

    Leave a comment:


  • Little
    replied
    Mine did that last October

    "I finally took it in . The transducer (HD-1) was bad. Cost me 60+120 labor. Guy said he only worked on 2 of these 180's before. That's good news.
    Bad news is when I started to weld, I found that I now had a scratch start tig! I was not a happy boy. Pulled the side cover off and saw a black wire dangling from the hv xformer to the resistor above. Plugged in the piggyback connector, and I'm good to go."
    Little

    Leave a comment:


  • frank865
    replied
    Check the cord going to the foot control, make sure nothing's damaged (hunk of metal dropped on it) shorting some wires. If it's OK see if everything is clean & looks OK inside the foot control...Sounds like something in the circuit is telling the welder the foot control is wide open...
    All this is assuming the welder is out of warranty! If it's still in warranty...CALL MILLER FIRST!!!!!
    HTH

    Leave a comment:


  • Tailshaft56
    replied
    I would pull the cover and check for a loose connection. Does the panel amp control work in stick mode or lift arc without the remote? Make sure the machine is clean inside and nothing is shorting out. IE Grinding dust.

    Leave a comment:


  • jmercado
    started a topic 180sd problem

    180sd problem

    I have a 180 sd, in tig when I press the remote pedal it makes the arc like if it is at 180 amps, even if the amp is set to 80 amps. Can somebody help.

    thanks
Working...
X