Announcement

Collapse
No announcement yet.

1999 Syncrowave 250 no dc and maxed ac

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 1999 Syncrowave 250 no dc and maxed ac

    I recently purchased a 99' model syncrowave 250 s/n kk269106 and when I fired it up on dc tig and pushed the pedal it kicked the breaker. So I switched it over to ac tig and pushed the pedal it was full blast. So thinking it could be the pedal I unplugged it and turned it off. Put it on dc and as soon as I turned the welder on it kicked the breaker. So I switched to ac and it will scratch start but again full blast. I've taken the covers off and blew it out. I did a check on the diode on the rectifier and it was good. (a buddy told me to check that. I have little to no experience with electronics) then he said to check the shunt. Which I discovered this model has the lem module and not the shunt. But I have no idea how to even test that. If any has any advice on what could be the issue or anything I'm all ears.

  • #2
    Sent you a PM. Check the resistances across plug 3 for the LEM. Also check the resistance across output terminals in DCSP and DCRP. It sounds like something is shorting out on the output when in DC.

    Comment


    • #3
      Ok thank you. I talked to a buddy that is a welder repair tech and he told me to check the scr's in the rectifier. I'm very new to electronics but I'm learning lol granted I hope the scr's are good because miller has them for like 212 dollars a piece and there's 4 lol but I did find a company that makes them and they are only 77 a piece so that's not as bad. While looking at the rectifier it looks like the main diode was recently replaced. I tested that and it is good. From all my research and reading I believe the person before me either tried gouging with the machine or shorted it out because the ground clamp is melted in two and seeing the main diode replaced. I just pray the pc1 is still good. I only have 800 in this machine and I would rather not drop another 800 to get the pc1 rebuilt.

      Comment


      • #4
        Ok soo I pulled all the scrs and it seems all 4 are shorted. When I apply pressure I have resistance gate to anode but nothing anode to cathode in either direction. I hope that's the correct way to check them. I know if they pass that test next you need to apply voltage to open them up but they failed the first portion so I'm assuming they are shot

        Comment


        • #5
          Something doesn't seem right. Did you try it in AC after you kicked the breaker on DC, or was that the last time? If all four rectifiers we're shorted, you would have kicked the breakers on AC.

          Comment

          Working...
          X