Announcement

Collapse
No announcement yet.

Spectrum 875

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • BBB-FAB
    replied
    I wanted to take a second to thank everyone for the input, Im grateful for your informed feedback.

    I just want to reitterate that I am not trying to slam Miller or allude to this Spectrum 875 being a lemon. The guy I talked to on the phone was a nice as it gets and went out of his way to look into this for me. I had just bought 3 new machines and unboxed them when I noticed this sound. Figured I would make 100% sure this unit was okay in case I needed to do an exchange. You fellas are having to deal with a plasma noob on this one. ;-)

    So thanks again!


    Click image for larger version  Name:	small.jpg Views:	0 Size:	52.4 KB ID:	613312

    Leave a comment:


  • jjohn76
    replied
    I noticed something similar on the 200 Dynasty and Maxstar auxiliary power supplies. They're basically buck converters off the rectified and boosted (~810VDC on the 200 Dynasty/Maxstar). The forward diode buzzes quite a bit in the audible range when the unit is idle (basically hysteretic/hiccup control mode) until there is sufficient current draw through the gate drivers to bring the switching to normal operation.

    Leave a comment:


  • Badger_Fan
    replied
    This is normal behavior. The internal AutoLine circuit usually switches at a frequency above the audible range, but on some units under a no load condition the switching frequency will become audible. The noise is not mechanical but rather is coming from some internal magnetic components.

    Leave a comment:


  • Aeronca41
    replied
    Never heard anything like that from my Hypertherm.

    Leave a comment:


  • BBB-FAB
    replied
    Originally posted by Auto_Tech View Post
    I'm not sure about all that noise in your box -- seems excessive in my view -- could be the power supply converting line AC, smoothing DC voltage, regulating current of something in the arc startup circuity (plasma arc spark prep). Definitely a lot of "rockin n rollin" going only -- relays (actually sounds like a bad relay with AC oscillating in it) or other things.
    I think I recall the nice person at Miller referring to the arc start-up circuitry in his explanation. As I have said from the beginning my opinion is not based in experience with this kind of product, but I am an IT professional and have worked around electronics for 35+ years and if thats normal that will be a first to me. Mechanical devices like Im hearing sure would seem to wear out fast if they never find some sort of equilibrium or a state in which they are at rest. I would just love to see another 875 like this one doing the same thing. My gut tells me this is gonna cost me $$$ eventually because whatever that is Im hearing, most likely will fail once the warranty expires. Thats how my luck usually goes. :-(

    Thanks for your input sir.

    Leave a comment:


  • Auto_Tech
    replied
    Unfortunately these plasma cutters (along with those from manufacturers like LE -- I have a 625 also) are Electro-magnetic Interference / Electro-magnetic Compatibility (EMI/EMC) trouble makers -- the products, harmonics, etc coming off these boxes are very dirty, broad spectrum based and will take out sensitive nearby electronics, components.

    I'm not sure about all that noise in your box -- seems excessive in my view -- could be the power supply converting line AC, smoothing DC voltage, regulating current of something in the arc startup circuity (plasma arc spark prep). Definitely a lot of "rockin n rollin" going only -- relays (actually sounds like a bad relay with AC oscillating in it) or other things.
    Last edited by Auto_Tech; 01-18-2021, 08:49 AM.

    Leave a comment:


  • cruizer
    replied
    Completely normal

    Leave a comment:


  • BBB-FAB
    replied
    I contacted Miller and was helped by a VERY nice gentleman on the phone. I made a video of what I am seeing/hearing and forwarded it to them and I was told that what is occurring on this 875 is normal. Being that this is a brand new machine, one of their higher-end torches and Im new to owning a plasma cutter, I just want to make sure I dont have a unit that has a bug or issue that is going to get worse. It just never stops clicking and buzzing and seems to a lay person like me that something isnt right.

    Here is the video I made, any of you guys have a 875? Does yours do this all the time?

    https://youtu.be/WXfkzfiOBis

    Thanks again for any information anyone can share.

    Leave a comment:


  • MAC702
    replied
    Clicking at roughly what frequency?

    Leave a comment:


  • BBB-FAB
    started a topic Spectrum 875

    Spectrum 875

    I am new to owning a plasma cutter and recently got a Spectrum 875.

    When my machine is powered on, I can hear lots of clicking noises while the machine is idle. It does indeed operate correctly, but when I put down the torch and not using it, sounds like all manner of relays or something clicking for seemingly no reason at all. Is that normal?

    Thanks in advance for any info.
Working...
X