Announcement

Collapse
No announcement yet.

Miller 302 trailblazer power problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Miller 302 trailblazer power problems

    My 302 trailblazer is producing 120v power for a couple seconds at startup. I tried checking rpms and they will not adjust on the machine display. I adjust the idle and the numbers stay the same. All display lights work. I couldn’t get it to strike an arc even when I have 120v.

  • #2
    What is your testing procedure and instrument to determine you have 120 V?

    What DOES the machine do when you attempt to strike an arc?

    Comment


    • #3
      All I’ve done is plug a grinder into it and hook up welding leads. When I start it, I tried to get it to arc and it does nothing but it will run a grinder for a few seconds. The display works perfect, I can adjust amperage. I initially thought to check rpms with the machine. It high speeds at 3780 and I can adjust the rpms but the digital display does not change. Basically I take it to idle and the display still shows 3780. I tested the 200 ohm resistor and it showing 196 ohms. It seems to me like it’s losing capacitance but I don’t know what or how to check.

      Comment


      • #4
        I found the problem RC24 came unplugged on PC 1. It’s working good again Thanks

        Comment


        • #5
          Easy fixes are good!

          You might want to inspect the connector for any overheating or loose contacts or anything like that, and if it came unplugged because a broken latch, add a couple zip ties.

          Comment


          • #6
            Easy fixes are good
            just hard to find glad you found it.

            Comment

            Working...
            X