Announcement

Collapse
No announcement yet.

millermatic 211 wont feed wire

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • millermatic 211 wont feed wire

    I went to use my MM 211 the other day and it wouldn't feed the wire. I have checked connections and ran continuity on the wires and checked the trigger. it all was good. then I jumped pins 1 and 2 still nothing. When you pull the trigger the rollers jump and the temp light flashes 3 times. if anyone can help it will be greatly appreciated thanks

  • #2
    Manual, page 32 - temp light blinks 3 times =
    Motor error. Check for birds nesting at wire spool and drive assembly. Verify proper drive roll alignment
    and tension, and that wire drive pressure assembly is closed. Contact nearest Factory Authorized
    Service Agent.

    Comment


    • #3
      I checked all that. I was hoping there was something I missed before I take it to the shop. Thanks for the information. have a blessed day.

      Comment


      • #4
        You should have told us the things you did first and save the time for us to look for that. Are you qualified to take covers off and use equipment to test live circuits in the machine? Can you supply the motor leads independently with a DC power source around 12V, like from a car battery?

        Comment


        • #5
          yes sir.

          Comment


          • #6
            If the unit is still under warranty I'd be talking to Miller -

            if not, your comment about the rolls jumping when you hit the trigger makes me think that something is bound up/frozen/stuck, and the drive is TRYING to work but is immediately going over current and triggering the fault condition.

            My next action would be to start dis-assembling the drive (being EXTREMELY **** and noting where and how each piece is oriented as they come apart) and confirming whether or not there is something "stuck" mechanically... Steve

            Comment


            • #7
              I got on line last night to see if it was still under warranty and it just so happens it will run out in 12 days. Thanks for the information though . Have a blessed day steve

              Comment


              • #8
                My millermatic 211 is doing the same thing, gas, power but no wire feed. 12 volt runs the drive motor fine. 8 months warranty left so we’ll see what they say.

                Comment

                Working...
                X