Announcement

Collapse
No announcement yet.

XMT 304 w/22A Wire Feeder

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Gamaffair
    replied
    Originally posted by MAC702 View Post
    The stock number under the serial number in the photo is for a CC-only version of the XMT 304.
    Thanks Mac702,,, very useful. I should have ckd here first before buying.

    Leave a comment:


  • Gamaffair
    replied
    Originally posted by jjohn76 View Post
    EDIT: Sorry I didn't mention this before, but this message is in response to troubleshooting your XMT 300...

    I haven't priced components for one, but running through some checks will let you know if it's worth fixing.

    I would first recommend downloading the manual. If you have a multimeter, first check the voltage across the four big capacitors in the bottom tray (two on each side). If they're still showing voltage across them, you will need to discharge them before you can safely work on the welder.

    Then check them for any dried fluid around the vent holes - they may smell a little weird too. This is what commonly causes the tripped breaker.

    Also check the input rectifier (SR1, furthers component back on the back right heatsink if you're looking at the front panel). When it goes, it usually blasts out the plastic case on the top or sides and you should see some black residue. SR1 has 5 connections, a row of two and a row of three. The row of three is from your input switch. The row of two is your + and - rectified voltage. Do a diode test with your multimeter from + to each input line, and from the - terminal to each input line. Check both directions - one should read about 0.6V, the other direction should read OL. If you see 0 volts, you will need to replace SR1. Look for the part number on the side and eBay will likely have it.

    Right next to SR1 is one of your inverter IGBTs (PM1) there should be a matching one on both sides. Check those for any blowouts on the side of the case as well. On both, find the terminal the says C2E1, and do a diode test (both directions) to terminals C1 and E2. If any read 0V, you likely have a bad transistor. If it is bad, there's a good chance the driver circuit is bad too. Please post with pictures if that is the case

    While you're in there, check the output diodes on the front heatsinks.

    Let me know if this helps, or post pictures if you get stuck.

    Jon
    Thanks John, Ill get to cking soon enough...

    Leave a comment:


  • MAC702
    replied
    The stock number under the serial number in the photo is for a CC-only version of the XMT 304.

    Leave a comment:


  • snoeproe
    replied
    Regardless of what the selector panel cover says, (perhaps it’s been replaced at some point), the machine is a cc only machine. You want a cc/cv version of XMT.

    Leave a comment:


  • jjohn76
    replied
    EDIT: Sorry I didn't mention this before, but this message is in response to troubleshooting your XMT 300...

    I haven't priced components for one, but running through some checks will let you know if it's worth fixing.

    I would first recommend downloading the manual. If you have a multimeter, first check the voltage across the four big capacitors in the bottom tray (two on each side). If they're still showing voltage across them, you will need to discharge them before you can safely work on the welder.

    Then check them for any dried fluid around the vent holes - they may smell a little weird too. This is what commonly causes the tripped breaker.

    Also check the input rectifier (SR1, furthers component back on the back right heatsink if you're looking at the front panel). When it goes, it usually blasts out the plastic case on the top or sides and you should see some black residue. SR1 has 5 connections, a row of two and a row of three. The row of three is from your input switch. The row of two is your + and - rectified voltage. Do a diode test with your multimeter from + to each input line, and from the - terminal to each input line. Check both directions - one should read about 0.6V, the other direction should read OL. If you see 0 volts, you will need to replace SR1. Look for the part number on the side and eBay will likely have it.

    Right next to SR1 is one of your inverter IGBTs (PM1) there should be a matching one on both sides. Check those for any blowouts on the side of the case as well. On both, find the terminal the says C2E1, and do a diode test (both directions) to terminals C1 and E2. If any read 0V, you likely have a bad transistor. If it is bad, there's a good chance the driver circuit is bad too. Please post with pictures if that is the case

    While you're in there, check the output diodes on the front heatsinks.

    Let me know if this helps, or post pictures if you get stuck.

    Jon
    Last edited by jjohn76; 03-28-2020, 10:08 PM.

    Leave a comment:


  • Gamaffair
    replied
    Originally posted by jjohn76 View Post
    Something isn't adding up. How well do you know the seller? You would probably need to call Miller Tech to see exactly which model it is, because your serial number points to a manual that covers both the CC and CC/CV models. It's pretty easy to replace that front cover and/or decals.
    Very true,,, something is not adding up for sure.
    it was an online purchase via eBay ...
    Looks like I opened up a claim early enough to return the item and get refund. I guess I'll be shipping back tomorrow.

    Thanks anyways for everyone help...

    Now on to my other issue, We had been using an XMT 300 for about 15 yrs or longer for mig welding application without any problems until last week when our breaker began to trip. Any idea where I should begin to look? I opened the welder up and everything looks visually good...

    I know that it is an older model but man its a work horse for repairing stud holes. Is it worth repairing to have as backup?

    Leave a comment:


  • jjohn76
    replied
    Something isn't adding up. How well do you know the seller? You would probably need to call Miller Tech to see exactly which model it is, because your serial number points to a manual that covers both the CC and CC/CV models. It's pretty easy to replace that front cover and/or decals.

    Leave a comment:


  • Gamaffair
    replied
    Originally posted by aametalmaster View Post
    Feeder plugged in the Remote?..I had that set up 20 years ago.Bob
    Yes 14 Remote plugged in. I ck tomorrow to see if it was pugged in any tightened properly.

    Leave a comment:


  • Gamaffair
    replied
    Originally posted by jjohn76 View Post
    I hate to say this, but you picked up a CC only Miller XMT 304, which won't mig weld well with that feeder. Unless you plan to use it for stick and Tig, it won't be much use in your shop. You would need the CC/CV XMT 304 or the newer XMT350 to mig with the 22A.
    The front of the welder does show CC/CV... but the "on the fly" processor selector does not give an option for "Mig"... see pic

    Gamy R.

    Leave a comment:


  • aametalmaster
    replied
    Originally posted by jjohn76 View Post
    You would need the CC/CV XMT 304 or the newer XMT350 to mig with the 22A.
    Thats what i had the XMT304, sorry...Bob

    Leave a comment:


  • jjohn76
    replied
    I hate to say this, but you picked up a CC only Miller XMT 304, which won't mig weld well with that feeder. Unless you plan to use it for stick and Tig, it won't be much use in your shop. You would need the CC/CV XMT 304 or the newer XMT350 to mig with the 22A.

    Leave a comment:


  • aametalmaster
    replied
    Feeder plugged in the Remote?..I had that set up 20 years ago.Bob

    Leave a comment:


  • Gamaffair
    replied
    Our setup...

    Leave a comment:


  • Gamaffair
    started a topic XMT 304 w/22A Wire Feeder

    XMT 304 w/22A Wire Feeder

    Hi All, I just purchased a used Miller XMT 304 welder to replace our older XMT 300 that we used for our daily mig welding needs. Problem with the replacement XMT 304 is that it does not have "MIG" on the panel to select as an option. Attached is pic of the front panel of the processor including the serial # from the back of the machine. We are using a Miller 22A wire feeder pictured as well.

    Please advise what we are dong wrong with our set up...

    CG Rodriguez
Working...
X