Announcement

Collapse
No announcement yet.

Maxstar remote issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Maxstar remote issue

    I have a maxstar 200 DC (2006 model), when I put it in Hf tig mode and turn on the remote the machine sense it and begins welding but it goes directly to the amperage on the display and will not throttle at all. When I turn the remote off, the machine stops welding as it should. I have tried a thumb control and a foot pedal and it acts the same every time. I have also done a factory reset and still no luck. Does anyone have any ideas what could be wrong and how to check it?

  • #2
    Is there 10 vdc at pins C and D on the remote?

    Comment


    • #3
      Agreed, do you have the 10VDC from pins C and D on the 14 pin connector on the Maxstar. And on your remote controls do you measure about 1,000 ohms from pins C to D?

      The Maxstar will auto sense to remote control function based on "seeing" the remote connected which is by seeing the resistance of the control potentiometer on those pins C and D.

      Comment

      Working...
      X