Announcement

Collapse
No announcement yet.

Trailblazer 302 problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Trailblazer 302 problems

    Hi everyone. I have a Trailblazer 302 gas welder that needed some work . I put new circuit boards in it because they were fried and now I've found that it will not idle down at all. I read about it maybe being the CTI or the throttle solenoid. Is there a way to test these? Also when the welder is running the display shows all 8's instead of amps and voltage. any help would be appreciated.

  • #2
    Does it have power on the 110v plugs? Does it have OCV? It won't idle down if you have a power problem and with all 8's seems like you do.

    Comment


    • #3
      I do have power at the 110 outlets

      Comment


      • #4
        So I just checked the OCV and it was like 9.5. Also this time the amp display says “on” and I could change voltage with the dial. Still not idling down.

        Comment


        • #5
          Just double checked the OCV, it’s actually 47 DC. My meter was AC last time. Also the displays are back to all 8’s

          Comment


          • #6
            Start by downloading the exact manual from the Miller ite. I am not sure about the Es***, but to check the idle solenoid pull the connector and check for 12v when it should be idling. To check the solenoid itself just apply 12v to it. Move the linkage by hand to make sure it is not stuck.

            Comment


            • #7
              Ok. So why I didn't do that first I have no idea, but I do not have 12 volts at the idle solenoid. Would that indicate that the CTI a.k.a. current transformer is shot? Also, where the power wire for the idle solenoid goes to the circuit board is the spot where the old circuit board had a burn mark.

              Comment

              Working...
              X