Announcement

Collapse
No announcement yet.

miller big blue 300d problems

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • miller big blue 300d problems

    Hello wondering if I can get some help with my miller big blue 300d, I replaced the voltage reg, and the main controller after I fried them from jump starting the welder. The machine welded great voltage was great, then I went out one day and started the machine and the voltage side read 0. Does anyone know why? Or what I should do now?

  • #2
    Starts at the brushes and works its way from there.

    Comment


    • #3
      Originally posted by itsme View Post
      Hello wondering if I can get some help with my miller big blue 300d, I replaced the voltage reg, and the main controller after I fried them from jump starting the welder. The machine welded great voltage was great, then I went out one day and started the machine and the voltage side read 0. Does anyone know why? Or what I should do now?
      Man, that was an expensive jump start! I am so thankful someone here warned me about jump starting my Trailblazer--it had a bad battery, and I was planning to jump it the next day....nice save from the guys here!

      Comment


      • #4
        Yeah in the middle of jump starting went to remove the cables and saw the warning on the side of the door......So 1997CST start at the brushes? I replaced them before replacing the other parts. How do I check the brushes?

        Comment


        • #5
          Like I said when I put the new parts on it started and welded great then one day no more voltage?

          Comment

          Working...
          X