Announcement

Collapse
No announcement yet.

Dynasty 200SD low buss voltage

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #76
    Originally posted by paulstef View Post

    I had to register on this forum to do one thing. To say THANK YOU!
    I was in the process of reverse engineering that PCB myself and was wondering why the flyback was only working occasionally.
    You mentioning that it needs Vbus operational was very helpful.

    It lead me to check where the 810V goes from RC1 on PC10. Found the first 750k resistor, part of the voltage divider of 3x750k, to be open circuit.

    You just saved me a couple of hours of troubleshooting. Thanks a lot!
    Glad it worked out!

    Comment


    • #77
      Hello Jon,
      I too want to thank you for all the investigation and documentation you have supplied. I have an older Dynasty 200DX that worked perfectly for years until it was returned to me non-operative.
      After sitting on a shelf for a long time I decided to try and fix it because I have a car restoration I am working on and my mig is not providing the results i need.

      Upon inspection I found the following damages on PC2:

      C10 - large capacitor, 5uf @ 1000V blown almost off the pc board.
      hole in pc board under what used to be C10
      C4 and C8 - 2 large buss capacitors show same blistering at the top you photographed
      C7 - small electrolytic shows some bulging.
      All diode tests pass EXCEPT the one you mention in post 11: RC4-6/8 and the C12/C13 point directly on the module. This fails (open).

      My first question is: have you put together any sort of schematic for the PC2 board?
      second: what would cause the roasting of C10 in such a manner?

      I am a EE, but not much experience with circuits like this, and I appreciate any help you can provide!

      Thanks,
      Thomas

      Comment


      • #78

        Hi everyone,
        I need help.
        My Dynasty not powering up at all.
        After buck drive repair, i powered it up, and found, that DC BUS volgate is 560V instead of 810V, panel wouldn't light up.
        So, PC10 board not functioning.
        In red color are my real measurements. It seems, all power signals are ok: 30V, +15V -12V.
        I found, that boost IGBT signal comes from U3 CD4093 4 pin (+15 V) and goes via transitors to RC1-4 pin. A this point is -12V, no generating any PWM signal. Do You have any ideas?

        I don't understand, what purpose is UC3845 PFC controller? U5 UC3854 14 pin shorted to ground. This pin is CT (Oscillator timing capacitor). A capacitor from CT to GND sets the PWM oscillator frequency. If 14 pin is grounded, this IC can't wok, i think. Also i can't find where 16 pin (Gate drive) is connected?


        Click image for larger version  Name:	PC10-1.jpg Views:	0 Size:	379.4 KB ID:	613564



        Attached Files

        Comment


        • #79
          John,
          PM sent. I never got around to the boost IGBT driver/controller section before giving the welders back. That said, it looks like the BJT Q29/Q30 is the totem pole driver pair, signaled from pin 4 of the CD4093. Pin 4 is the NAND output of pins 5 and 6, which is worth tracing back to their sources. My guess is one will originate at UC3854 and the other one will likely originate from an opamp or comparator used as a zero crossing detector, or at least low threshold detector for the inductor current (LEM feedback). Here's why:
          The UC3854 is a fixed PWM controller that works well in continuous conduction mode through discontinuous conduction mode. However, I don't remember seeing turn on snubbers (inductors present) for the boost IGBT, which likely rules out continuous conduction mode because of the high turn on loss. Discontinuous conduction mode works, but will mostly likely have higher peak currents than a Critical/Transition Conduction mode controller, which charges up the current in the boost inductor to the reference current (duty cycle will always be below 50% because the bus voltage is so high), then shuts off and waits until exactly when the inductor current returns to zero before it turns back on. This creates a variable frequency PWM, which the UC3854 isn't designed to do.

          The way around this is to use the UC3854 only to determine the correct turn on time based on the output voltage error signal (difference from 810V reference), the input voltage waveform (input current needs to follow the input voltage sinewave shape for greatest power factor), and compares this to the current across the boost inductor. To figure out the off time, use a circuit that measures the inductor current, and when it drops below a certain value, turn on the IGBT.
          Hopefully that makes sense. Either way, if you trace back pins 5 and 6 on CD 4093, we can figure out if that is what's happening.

          ​​​​​​Jon

          Comment


          • #80
            John,

            Last thing, check out this guy's work on that board. It's much easier to trace out the schematic with the board unpopulated in these photos. It doesn't show the ground or power planes, but you can get those pretty easily by holding your board up to the light and seeing where the cross-hatched connections are.

            https://www.element14.com/community/...-200841#273474

            Comment


            • #81
              For the group, John (alvideo above) converted all of my chicken scratch schematics (and then some) for the boost card below. This is awesome work! He has also drawn out the PFC boost circuit, though which seems to me like it's using a fixed frequency PFC chip (UC3854) in a variable frequency control system. As far as I understand it, it looks like average mode control to set the on pulse width, then uses the rectified voltage to determine the variable off time. Please let me know if I am off. Also, if you're working on the board, please confirm the schematic, particularly in the lower right and upper right. Something seems off about the wiring for that quad NAND IC.
              I am about to start working through an XMT 350 (the micro-controller and peripherals look ok right now), and will do what I can for a schematic. It probably won't be as clean as John's work though...

              Jon
              Click image for larger version

Name:	Miller Dynasty 200 PC6.jpg
Views:	80
Size:	1.37 MB
ID:	615167

              Comment


              • #82
                Nice!

                Miller really should be providing these...

                Comment


                • #83
                  Bushy, I don't disagree, but would imagine it's more liability than anything. I am making a big assumption that folks who would spend the time going through that schematic would spend the time drawing the schematic for the board when the welder comes up in the queue - it's just a time saver and bumps the welder up the queue a bit. I throw out the caveat that I haven't been able to compare the PFC circuit (bottom) and boost driver circuit to the board. It doesn't make sense to me how the output signal from the boost inductor current comparator (bottom right, traces along the right edge of the paper) connects to the SR latch on the Quad NAND gate in the upper right. Also it looks like that opamp circuit in the upper right sets the off time based on the input rectified voltage, but I don't quite see how it triggers the SR latch and the NAND gate that signals the output driver. Hopefully that made sense...

                  Anyways, I am starting on the XMT 350 shortly - I have one with a fried auxiliary power circuit.

                  Jon

                  Comment

                  Working...
                  X