Announcement

Collapse
No announcement yet.

Dynasty 200SD low buss voltage

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #46
    Noel, I think it is comparable to the mechanical systems in cars, though tougher to see. My posts are pretty long, but the concepts hopefully aren't too difficult when you compare them to a direct injection engine and automatic transmission. But like these circuits, it gets real when you have to troubleshoot a diesel injection system or rebuild a valve body. At least it does for me...

    Comment


    • #47
      A couple post to show progress, I bypassed the flyback circuit and powered up PC1 directly with +15V (RC3-6) and -15V (RC3-5) tied to a common reference ground (RC3-8 or RC3-9). One thing to note for those trying this, both those circuits pull very different loads (+15V pulls much more than -15V, at least when none of the big accessories are running), so trying to use a 15V linear regulator or a 15V zener to set the ground reference didn't work. I ended up finding an old +12/-12V regulated power supply that worked for testing.


      So this machine definitely had a lot of use!

      I also put power on the flyback secondary circuits, again (applied right after their forward diodes) with all accessories plugged in, and all is well.

      So it's back to the flyback transformer primary control. Aero, something tells me I should just replace Q11 on PC10. When I measure voltage across R13 and R14, even with R14 tied to ground, R14 has 14.38V across it when R13 has about .1V. Also, when the machine is off, both resistors are reading way out of spec. I think Q11 is damaged, which is putting R13 in parallel with R10 and R14 in parallel with R9/ R10 (PC2) R12 from PC2. Does that make sense?

      Also, I still need to figure out why R11 is showing ~17V. I think for some reason Q2 on PC2 is on, pulling that current feedback circuit up to the 30V reference. Maybe it's Q2, but needs further investigation.

      Comment


      • #48
        Originally posted by jjohn76 View Post
        Noel, I think it is comparable to the mechanical systems in cars, though tougher to see. My posts are pretty long, but the concepts hopefully aren't too difficult when you compare them to a direct injection engine and automatic transmission. But like these circuits, it gets real when you have to troubleshoot a diesel injection system or rebuild a valve body. At least it does for me...
        I seem to know a little about a lot and some of that little is on a shelf at the back covered in dust. I like your posts because while I don't always get it, I manage to get something. Even if that something is how to make better sense of things. I'm looking forward to doing the wiring and electrical in my car projects. Lots fear that but I'm excited to tackle it. Drunk with the courage your providing that day will come.

        Comment


        • #49
          Another update on the flyback circuit- I checked the last feedback loop and found another component out of spec. Here's the updated flyback circuit, where I left off a diode (D7 on PC2). The secondary outputs aren't complete, but not needed for troubleshooting just yet.
          Click image for larger version  Name:	IMG_20191023_142707688.jpg Views:	1 Size:	38.5 KB ID:	603688
          So this flyback circuit doesn't have an oscillator or some way to routinely turn mosfet Q1 on and off. It basically turns it on when four conditions are met, and turns/keeps it off when any of the four conditions are not met. It does this through four feedback loops.
          1. Voltage feedback from the secondary output, along the top edge of the schematic above. Anytime the measured secondary output voltage is higher than 30V (measured between the +15V and -15V references for the PC1 board) plus the optocoupler led voltage drop, the mosfet is turned/kept off.
          2. DC buss voltage feedback. This is in the middle of the schematic, controlled by U2 on PC10. It only enables the mosfet to turn on when the DC buss voltage is at the designed 810V (input circuit is working properly).
          3. Current feedback. This is the loop along the right edge and bottom of the schematic. It measures the current across resistors R8/R9 on PC2, and turns off the mosfet anytime this current exceeds about 3 amps (based on the Q8 threshold voltage).
          4. Flyback voltage feedback. This is what Q2 on PC2 monitors. Basically, anytime the transformer primary voltage is higher than 30V (flyback voltage, transferring power to the secondary outputs), Q2 conducts, which turns on Q8 (PC10) and keeps the mosfet off. This ensures the flyback transformer stays in discontinuous conduction mode.

          So basically, the control system monitors when the secondary output voltage drops below 30V and the flyback secondary voltage returns to 30V, makes sure there is 810V on the DC buss, then turns mosfet Q1 (PC2) on until the primary current in the flyback transformer builds to the set limit, then turns off. This sudden turnoff causes a voltage boost (flyback voltage) on the primary that transfers energy to the transformer secondary. If this was enough energy to get the output secondary voltage above 30V, then the controller just waits until the voltage drops enough to trigger the mosfet again. If not, then the controller waits until all of the flyback energy is dissipated/transferred to the secondary, then triggers again.

          Anyways, as soon as I get the time, I'll replace Q8 and Q9 on PC10, as well as Q2 and D7 on PC2, then recheck all components before powering up on a bench supply.
          ​​​​
          Last edited by jjohn76; 10-25-2019, 01:37 PM.

          Comment


          • #50
            After swapping a couple of components for the Flyback controller, I checked over all circuits again and powered it up. One thing I am realizing - either every one that breaks and my buddy finds is noisy, or all of these Dynasty/Maxstar 200s are noisy...

            Click image for larger version

Name:	15721104419601954152723.jpg
Views:	167
Size:	64.3 KB
ID:	603756


            Comment


            • #51
              Everything is back together and you would have thought I was deliberate enough in testing to run it on AC for aluminum - several inches of ugly black welds until I realized that... At least the gas was on... Anyways, once I pulled my head out of it, I could get clean melts, will try with filler tomorrow. I will probably try a bunch of rods on AC and DC before I give it back to my buddy. I hope this thread helps anyone wanting to troubleshoot.
              Jon

              Comment


              • #52
                It has Jon. Couldn't find one of those however so I'll settle on this Snap ON scan tool. Brave enough to look now anyways, whether or not we can save it, that waits to be seen.
                Click image for larger version

Name:	IMG_6923.JPG
Views:	150
Size:	137.2 KB
ID:	603793

                Comment


                • #53
                  Originally posted by Noel View Post
                  It has Jon. Couldn't find one of those however so I'll settle on this Snap ON scan tool. Brave enough to look now anyways, whether or not we can save it, that waits to be seen.
                  [ATTACH=JSON]{"data-align":"none","data-size":"medium","data-attachmentid":603793**[/ATTACH]
                  Noel, what is it doing or not doing? If it's a power up issue, the left side looks to be the power supply.

                  Comment


                  • #54
                    I'm not sure what I'm doing actually? I just knew it came into my ownership with a powering up issue and I said I'll get to it eventually. Reading your posts I decided to get brave and open it up. So I did. And it still doesn't
                    power up, what's up with that eh? I even dropped the couple of bucks on a new 9V alki battery still no go? Not even a blinky. I did bring in my digital multi meter so I'm going do some checking things out eventually.

                    With little invested I thought it would be a nice change to some of what has been keeping me busy, and offer a challenge in problem solving in the warmth and comfort rather then a cold drive way.
                    I do have a GM Tech 2 that seems to fit my needs so I'm not pressed to actually fix the thing, rather thought to use it as a learning experience to better understand how all those little doo dads made magic happen.

                    It did come with a box, and I do mean box of reading material. I'll take a picture. I'm not sure if half the books are french but I'm hoping to find a circuit diagram on one of those pages thats in english?

                    I just didn't want you to think your efforts in explanation were in vain. Without that effort, this would still be sitting in the corner with no chance of me fixing it. Now there's a chance. 30/70?

                    Comment


                    • #55
                      Maybe to get you to 32/68... it's probably worth starting on the left side. That one chip lying flat with three leads is your voltage regulator. You can check for continuity from the bottom lead to the positive battery connector and check for continuity from the middle lead to the negative battery connector.

                      Comment


                      • #56
                        Originally posted by jjohn76 View Post
                        Maybe to get you to 32/68... it's probably worth starting on the left side. That one chip lying flat with three leads is your voltage regulator. You can check for continuity from the bottom lead to the positive battery connector and check for continuity from the middle lead to the negative battery connector.
                        Thanks Jon, I must be the one guy who didn't know that because I didn't! I did look it over though. Nothing stood out as "oh...doesn't that's looks fried?"

                        I mentioned in another other post recently buying a non running Kia. The gentleman I bought it from woke in the night to take a leak and experienced numbness on his right side. Didn't think much of it but upon waking in the morning discover he couldn't speak. He had a stroke.
                        Brain it seems worked, he could write out that he couldn't speak, but when he tried words didn't come out. Talked like a 3 year old, his words.
                        Took nine months of therapy and he's now mostly talking again as before the stroke, but he struggles at times for an occasional word in descriptive conversation.

                        I'm a guy who takes apart and puts back together. Reading comprehension while good, I wouldn't call strong and for that reason I'm constantly finding ways to make a picture from the words. I dropped biology never having hooked a battery to a dead frog to watch it twitch, however, I did successfully wire a tilt steering column in a old 65 Chevelle giving me a horn that worked and 4 way flashers? This looks harder?


                        I'll catch this up later by starting a new topic. Not quite welding but maybe there's an interest anyways?
                        Taking a break as the garage airs out the stink from spray can painting small hardware car parts,
                        32/68 sounds pretty good!
                        I'll report back a little later on what I discover.

                        Comment


                        • #57
                          Originally posted by jjohn76 View Post
                          Maybe to get you to 32/68... it's probably worth starting on the left side. That one chip lying flat with three leads is your voltage regulator. You can check for continuity from the bottom lead to the positive battery connector and check for continuity from the middle lead to the negative battery connector.


                          Click image for larger version

Name:	IMG_6943.JPG
Views:	146
Size:	115.3 KB
ID:	603815Well Jon, I have two of those black things with three legs. Per your instructions I checked them both. I would have sworn when I first checked for continuity the top one in this picture (right side in the picture below) checked as you mentioned with continuity from the negative terminal to the middle leg. The positive showing an open circuit on all three legs.

                          The bottom showing continuity from the negative terminal to the top leg, the positive terminal showing open on all three legs.



                          Click image for larger version

Name:	IMG_6946.JPG
Views:	137
Size:	95.3 KB
ID:	603816However...I was doing what I do best which is to say messing about and now the little black thing on the left ( bottom in the upper picture), shows continuity to the middle leg from the negative terminal, open from the positive to all legs. The one on the right shows continuity from the negative terminal to the far right leg, the positive reads open on all legs.

                          I could be confused on my earlier readings, but as it sits, LM340T5 shows continuity from negative to the center leg, open to all leg from the positive terminal.

                          Looking at the picture, when continuity is checked from the stud to the three legs, both show continuity to the middle leg. If that tells you something I'm all ears Jon. I know you didn't ask that but I was on a roll you know?

                          If it turns out I screwed this up let me know. Thanks again Jon.



                          Comment


                          • #58
                            Noel, the one on the left is your 5V voltage regulator from the batter, which is what that 7805 marking means (the 78 series are voltage regulators with the last two digits telling you the voltage). The one in the right is a mosfet (RFP8N18L), which probably does all of the switching for the other power supplies on the board.

                            The 7805 takes in the raw voltage (should be in this case the 9V battery, but possibly not) on the left leg (positive lead) and middle leg (negative lead), then puts out a steady 5V across the right leg (positive) and middle leg (ground). If it isn't connected to the battery terminal, it's probably worth tracing it back to the battery. What resistance do you get across the left and middle leads, and the middle and right leads?

                            Comment


                            • #59
                              Originally posted by Noel View Post



                              [ATTACH=JSON]{"data-align":"none","data-size":"medium","data-attachmentid":603815**[/ATTACH]Well Jon, I have two of those black things with three legs. Per your instructions I checked them both. I would have sworn when I first checked for continuity the top one in this picture (right side in the picture below) checked as you mentioned with continuity from the negative terminal to the middle leg. The positive showing an open circuit on all three legs.

                              The bottom showing continuity from the negative terminal to the top leg, the positive terminal showing open on all three legs.



                              [ATTACH=JSON]{"data-align":"none","data-size":"medium","data-attachmentid":603816**[/ATTACH]However...I was doing what I do best which is to say messing about and now the little black thing on the left ( bottom in the upper picture), shows continuity to the middle leg from the negative terminal, open from the positive to all legs. The one on the right shows continuity from the negative terminal to the far right leg, the positive reads open on all legs.

                              I could be confused on my earlier readings, but as it sits, LM340T5 shows continuity from negative to the center leg, open to all leg from the positive terminal.

                              Looking at the picture, when continuity is checked from the stud to the three legs, both show continuity to the middle leg. If that tells you something I'm all ears Jon. I know you didn't ask that but I was on a roll you know?

                              If it turns out I screwed this up let me know. Thanks again Jon.


                              Noel,

                              ​​​​​Also, I can't see the complete circuit, but wouldn't think the mosfet (top one) would have the middle leg (drain) grounded. It's basically a switch that connects the middle leg (drain) to the right leg (source) when there is a positive voltage applied between the right leg and left leg (gate). It would be worth using the diode tester and checking between the middle and right leg in both directions. With positive lead on the middle leg and negative lead on the right leg, you should get open loop. With positive lead on the right leg and negative lead on the left leg you should get ~.5V.

                              That left side provides a bunch of different voltages throughout the scanner - you can tell by all of the diodes on the upper left side of that board. It's been a dozen or so years since I messed with the OBD II, but remember they had both a positive and negative voltages.

                              ​​​​​​Have you pulled the board out of the case? Any pictures of the back side?

                              Comment


                              • #60
                                Click image for larger version

Name:	IMG_6949.JPG
Views:	134
Size:	111.0 KB
ID:	603823Click image for larger version

Name:	IMG_6951.JPG
Views:	129
Size:	121.4 KB
ID:	603824Click image for larger version

Name:	IMG_6953.JPG
Views:	130
Size:	111.0 KB
ID:	603825Click image for larger version

Name:	IMG_6954.JPG
Views:	128
Size:	113.5 KB
ID:	603826Click image for larger version

Name:	IMG_6955.JPG
Views:	125
Size:	117.4 KB
ID:	603827 I took a few more pictures this morning Jon, as I mentioned, I've got the taking things apart down to an art form. Figuring things out, not so much.

                                I'm short on time this morning to focus this effort but will reply later this evening in greater detail following up with the answers to those questions. Your assistance is appreciated big time.

                                Comment

                                Working...
                                X