Announcement

Collapse
No announcement yet.

Miller legend 200 no 240v or 120v

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Miller legend 200 no 240v or 120v

    i tried looking this up before I posted, I have an older Miller legend 200. The 2 120v plugs don’t show any voltage aswell as the 240v plug. The single 120v plug does work. I’ve cleaned grounds, and cleaned the I believe r5 bands? Anyone had this happen before I purchased it this way I have not tried welding with it yet so I’m not sure if the welder portion is operational either, but the previous owner said that was still working after he lost the plug ins. He said it all started after he replaced some engine parts on it not sure if that’s true or not.

  • #2
    Remedy
    No auxiliary power output at receptacles RC1, RC2, or RC3.
    Run engine at power/idle speed.
    Reset circuit breakers CB1 and CB2. Effective with Serial No. KE629034, also reset circuit breakers CB5 and CB7 (see Section 4-3).
    Check receptacles RC1, RC2, RC3 for continuity and proper connections. Replace receptacle(s) if necessary.
    Check connections to terminal strip 1T.
    Clean slip rings, and install new brushes if necessary (see Section 6-15).
    Check coil voltage and connections of control relay CR4. Check continuity of coil and condition of contacts. Replace CR4 if necessary.
    Check diode D4, and replace if necessary.
    Check idle board/module PC1 and connections (see Section 6-5).
    Check control transformer T1 for signs of winding failure. Check continuity across windings, and check for proper connections. Check primary and secondary voltages. Replace T1 if necessary.
    Disconnect leads 21, 23, and 33 from brushes, and check continuity across slip rings. Replace rotor if necessary. Disconnect leads 48 and 49 from voltage regulator board PC2, and check continuity between leads 48 and 49. Disconnect leads 50, 51, 52, and 53 from stator. Check continuity between leads 50 and 51, and 52 and 53. Replace stator if necessary.

    Comment


    • #3
      I guess first off you need to see if it welds

      Comment


      • #4
        Also check the power/weld toggle switch.

        Comment

        Working...
        X