Announcement

Collapse
No announcement yet.

Battery charging option not working

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Battery charging option not working

    I have a trailblazer 325 with Excel and battery charging option. This machine has been great until I tried to jump start a battery and it just didn't work. The display shows that it was switch on, but no power to cables. Also my excel power is not working. My display jumps all around like there's a load or I'm welding even when I'm not. The engines changes speed erratically even when there's no load. I only have 150 hrs , but was past my warranty for time. I went ahead and spent the money and got a new circuit board, but to no avail. I guess there are two circuit boards and I think my only choice is to spend another $900 on a new board and hope it works. Any help would be appreciated. I just love this welder otherwise

  • #2
    That isn't your ONLY choice.
    Throwing $900 lumps of cash at it doesn't sound too savvy.
    If the board actually is/was blown...then it's hard to say if you fixed it. Maybe something blew the first board and you didn't find or change the actual faulty part. So you put another one on there and blew that too.
    Miller has a good habit of working with people who are out of warranty but low hours.
    Sometimes fixing your own stuff isn't the way to go.

    www.facebook.com/outbackaluminumwelding
    Miller Dynasty 700...OH YEA BABY!!
    MM 350P...PULSE SPRAYIN' MONSTER
    Miller Dynasty 280 with AC independent expansion card
    Miller Dynasty 200 DX "Blue Lightning"

    Miller Bobcat 225 NT (what I began my present Biz with!)
    Miller 30-A Spoolgun
    Miller WC-115-A
    Miller Spectrum 300
    Miller 225 Thunderbolt (my first machine bought new 1980)
    Miller Digital Elite Titanium 9400

    Comment

    Working...
    X