No announcement yet.

Miller 235G Plus - Fully Operational

  • Filter
  • Time
  • Show
Clear All
new posts

  • Miller 235G Plus - Fully Operational

    Hey Everyone,

    I recently acquired a Miller 225G Plus from someone who purchased it at an auction but never ran it. It has SN: KF945065 and Stock No: 903372. The hour meter shows less than 500hrs. It has a 16hp Onan P216 engine, which I am semi familiar with, so I pulled the carb off, cleaned it up, checked for spark and got a new battery for it. With a little time and fresh fuel I got it running. Engine runs pretty smooth but I am not sure everything on the welder/generator side is fully functional or functioning properly for that matter. This is my first gas drive welder.

    When I start it up it runs fine in the RUN(Rabbit) speed and the 120v duplex receptacles work and power a light bulb. However when I switch the speed to RUN/IDLE (Rabbit/Turtle) the light goes out and the welder unit doesn’t run up to speed to power the light. I haven’t tried the actual welding feature at all because I have not gotten my hands on any cables yet.

    I have the basic owner’s manual for the welder and have skimmed through it but am not entirely sure what my problem could be. Based on the trouble shooting suggestions it could be engine speeds, a fuse, or the Auto Idle Module PC1 or current transformer Ct1. Since the engine is running smoothly right now, I am hesitant to mess with that unless that is the most likely culprit. I know there is a fuse for the low power output but haven’t removed the hood yet to locate it. Is there any diagnostic testing that I can do prior to busting into the electronics under the hood to determine the culprit of my problem?


  • #2
    One simple test you could do without taking the hood off would be to check engine speed. Best way is to measure the frequency at the AC power outlet using either a multimeter with a freq mode or a Kill-a-Watt meter from HD or Lowes. It should be about 62 Hz on high speed and 37 Hz on slow speed. There is a procedure in the manual for speed adjustment. But my guess is there is something else wrong. Best get some leads and see if it will weld. May well be the idle pcb or CT1; or a bad connection somewhere.


    • #3
      I have acquired leads and a kilowatt meter. When starting in Run (rabbit / weld mode) I measure 61.5 Hz and voltage varies between 103 and 105V. When I switch to Idle/Run (turtle/rabbit) the kilowatt meter does not light up and register a reading.
      I hooked up welding cables and tried to strike an arc in all setting positions with no luck. So, I have now removed the hood and checked F1 and F2 fuses. They both appear to be fine. I am currently going to get more fuel, contact cleaner and possibly borrow a tach to check engine speed.
      I have read many of the other forum posts for the Bobcat not outputting. I am currently trying to locate the flashing diode. Question - does it actually flash?
      Also, I am looking for guidelines/tutorials for checking the brushes. I have found the electrical schematic on the inside of the side panel. It is SB-164 335-D and I am looking for a larger, more clear copy of it.


      • #4

        Here is the correct manual with a bigger diagram.

        I dont know know for sure-need one of the welder experts -- but your low output voltage could be due to low engine speed. I know it's sensitive but not sure how sensitive. Step up RPM to get 62.5 hz with no load and then see what voltage you get. I believe the freq meter is more accurate than a tachometer.

        The flashing diode does not flash, but that's a legit question. It's called a flashing diode because back in the days before they were included in welders, you had to manually "flash" the field with a battery if the welder had sat unused long enough for the residual magnetism in the field to decay away, and the generator would not produce power. The battery connection generated a flash when you did it; thus the name.
        The flashing diode is D4 in the upper left section of the schematic on page 28. It is physically shown on page 39 at Find No 1.

        Most important. thing with the brushes is that they must be absolutely free sliding in their holders with good spring tension on them-good contact with the slip rings is essential. Check the manual - there may be a spec for minimum brush length but if the hour meter is right on your machine they should not be worn down.

        Some troubleshooting thoughts:
        -rotate both selector switches thoroughly their entire ranges a number of times-slowly. Sometimes that will clean off some crud and get it working

        -do all your troubleshooting on AC WELD-that takes the diodes and a lot of internal connections out of the circuit and makes it easier to trace the problem.

        -rotate the fine amps adjust knob through its full range a number of times

        -replace the fuses even if they look and check good. I've been stung on that one before; there are examples on this site. Not likely the problem but possible.

        Are you comfortable and trained for safely taking voltage measurements inside a running machine that can easily kill you ? If not, get some qualified help before digging in too much further. Lots of juice in there. Keep us posted on progress! Can provide more things to check if this doesn't do it.
        Last edited by Aeronca41; 10-28-2017, 05:49 PM.


        • #5
          Thanks for the manual. I found that one as well. Glad to know it is the right one.
          I went through and cleaned each connection under the hood with a brass brush and electrical cleaner and reassembled it. I also used 0000 steel wool very very lightly on what I think are the rings. I am still trying to find the stone things that people talk about to clean them and how to do it.
          Anyway, I now have welding output in AC and DC positive. I haven’t checked the other settings yet, nor the setting for using a wire feeder (since I don’t have one). I am now having 120 to 125V in AC at my plugs and I now can most of the time get the generator motor to come up in speed from the idle to run after pulling a drill motor trigger a few times. The time it takes to get it to come up in speed varies and seems like it is erratic. Sometimes it is fast, other times it takes awhile. This may be things just working themselves into running order. I am still unable to get a hertz reading out of the outlet when in the machine is in Idle/Run. It only gets a reading once the motor spins up and it gets 61.4 Hz.
          I bought this for a screaming good deal on craigslist. It had sat for at least 4 years and for the price I paid I thought it would be a good experiment to see if I could get it running. Aside from a couple basic parts that appear to be missing from the carb / aircleaner and some lack of attention I think that this unit should run reliably. The unit has >500hrs on it and I was reluctant to put much money into but considering I now have AC power and it seems to weld I am going to go ahead and buy the needed parts for the engine.
          I am interested in knowing any preventative maintenance or items I should look at that could potentially be a deal breaker on this engine. I still, as said previously, cannot get a hertz reading from the kilowatt meter when in Idle. I am having intermittent issues with the fuel pump or vacuum in the system as I am not keeping the inline fuel filter I installed even half full during run. I have tried to clean the tank as best as I can but am still having issues with the metal tube for fuel coming out of the tank.
          Pro-Tip: It is never a good idea to blow into a line connected back to a gas tank without removing fuel cap…leaves a nasty gas taste in the mouth. Perhaps some can comment, is it common to use a 12V pick-up fuel pump to provide sufficient fuel pre- mechanical engine driven pump?
          Again, if there is anything else I should check before dumping in more money to restore it, please let me know, I am all ears. I greatly appreciate the feedback and help from the community on this subject.
          Thanks again!


          • #6
            Use the right oil. Regular ole car oil is not sufficient for air cooled engines.


            • #7
              I wouldn't expect to have voltage at the outlets in idle. I think that machine only provides utility power in "weld".

              Saw in another thread a hint about checking oil level-if it's too full, the pulse-operated fuel pump won't work well.

              I have the 20 hp version of that engine (P220) on my Trailblazer 280. No issues with it other than the Onan tendency to carbon up if not run hard now and then, which I have not personally experienced. Look up Cruizer's posts here on decarboning (doing it at night, so you get to see the fireworks). With the low hours you have I wouldn't expect too much carbon, but who knows? The engine manual is avail thru a link embedded in a response somewhere on this forum, I think. Do some searches on Onan and P216 or P220.

              One warning from Cruizer is NOT to use regular automotive oil--the zinc level is way too low and will destroy the cam and lifters. He recommended Quaker State Defy, Shell T6 synthetic diesel truck oil (5w-40) or high-quality motorcycle oil. I've switched to T6; working well.

              Fuel line pro-tip noted. Thanks!


              • #8
                Guys I am still having intermittent Idle to Run issues and am looking for some advice. I followed the process duaneb55 describes below. the link to the original thread is below as well. My findings while running through the procedure are in red.

                "On the Bobcat 225, the solenoid energizes to bring the unit to low idle speed and de-energizes to increase to weld/power speed.

                If the solenoid coil proves good with the continuity check and it pulls in on the battery test, make sure there is 0 volts AC between idler control module terminals G and E with the unit running and no weld/power load on the unit. Continuity was good and it pulled on battery test. Measured .024 VAC between G & E when the unit was running.

                Confirm there is battery voltage between idler module terminals B and E with STOP/RUN/START switch in RUN/IDLE position. Measured 12.5 VDC between terminals B & E with the unit off but the switch in the Run/Idle position.

                If the above checks out and there is no battery (+) voltage at idler module terminal C after 15-20 seconds with switch in RUN/IDLE position after a weld/power load is removed or after unit is first started, the idler module is bad
                . Measured approximately 0.03 VDC at terminal C"

                Lastly, From another forum duaneb55 mentioned checking continuity between the solenoid that energizes in order to pull motor into idle. Testing that showed continuity with the engine off.

                Any other feedback is always much appreciated.



                • #9
                  Hey guys,

                  In have a question on the Onan engine. When I got the welder the airfilter box was not attached. When I got it cleaned up and ready to attached I realized the breather tube that seats in the air filter pan was just a a piece of fuel hose that had been cut and shoved in place but didn't fit the holes really well. I have been searching for the actual breather tube but all I am finding in regards to the P216 Onan motor is the molded rubber piece purchased below but the 2 parts it's intended to connect are in alignment. Is there a specialty part that was just for the P216 used by Miller?


                  • #10
                    Looks similar to my b48 onan mine has a diff aircleaner might not be the right one look online for a manual should be a parts breakdown on that


                    • #11
                      I have the manual for the P216 motor with parts break down and it shows the molded rubber part or it shows a copper tube going to the metal cap thing that is there in my photo. The copper tube is supposedly for the NG version but my motor looks to have always been gas. Gas cap says GAS ONLY and there is a gasoline only sticker on the body by the fill port. I will look for a b48 engine manual for comparison.



                      • #12
                        Originally posted by whizbang View Post
                        When I switch to Idle/Run (turtle/rabbit) the kilowatt meter does not light up and register a reading.
                        Sounds as if you picked up the less expensive $20 version of the Kill-A-Watt meter which cuts out around 40-45Hz. Click image for larger version  Name:	0075154904400_300X300.jpg Views:	1 Size:	27.7 KB ID:	586752

                        The next version up $30 unit will register into the 30's where it needs to in order to set the proper low idle speed (35-38Hz or 2100-2300RPM) to keep the generator and auto idle system functioning.
                        Click image for larger version  Name:	image_35742.jpg Views:	1 Size:	25.9 KB ID:	586753
                        As a test, I suggest just increasing the low idle speed in increments to see if or until the auto idle functions with your drill load applied.
                        Last edited by duaneb55; 11-30-2017, 08:47 AM.
                        MM200 w/spot controller and Spoolmatic 1
                        Syncrowave 180 SD
                        Bobcat 225G Plus LPG/NG w/14-pin*
                        *Homemade Suitcase Wire Feeder
                        *WC-1S & Spoolmatic 1
                        PakMaster 100XL
                        Marquette "Star Jet" 21-110