Announcement

Collapse
No announcement yet.

Trailblazer 250G AC welding output issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Diodes are not in the circuit for AC weld so connections there not likely to be the trouble. However, the basic issue of connections somewhere has to be the source of the problem.

    Comment


    • #17
      There is not diodes in the metal rectifier ?

      Comment


      • #18
        Originally posted by D Auger View Post
        There is not diodes in the metal rectifier ?
        There is no rectifier in the AC side. Rectification turns AC into DC.

        Comment


        • #19
          Sorry for the confusion

          Comment


          • #20
            The only people who never make a mistake are those that don't do anything! No problem!

            Comment


            • #21
              Thank you

              Comment


              • #22
                Hey guys. I took apart and cleaned both ends of the connections on the AC/DC selector switch that we're easily accessed without taking too much else apart and there was a little change but not what I'm used to on AC. And I do know that every machine is different but it should still initially strike an arc just like it does on dc and I shouldn't have to bury the rod in the puddle physically touching the metal and dragging the rod along. And the amperage shouldn't have to be set so high to do so that the rod gets so hot that it bends. I even took a flat file and lightly filed the copper contacts of the switch but that didn't help either. I know I can probably get by as many people do with just dc but I'd like it to work on ac as well for a future tig setup. Can someone tell me what output voltages I should see at the studs? I had them written down somewhere but I can't find them.
                Now my understanding is that the generator puts out ac current, correct? And the brushes only have to do with dc, correct? I'm asking because I took my brush holder out again and discovered a different, narrow wear pattern, but still welds good on dc.


                Thanks

                Comment


                • #23
                  You are mostly correct.

                  First, if you check the specs in your manual you will find the open circuit (while you're not welding) voltage should be about 75 VAC. I wouldn't be surprised if you see that since there is no current being drawn but I suspect it is dropping way down when you try to weld.

                  There are three brushes, which do pass only DC, but not the DC weld current I'm guessing you are thinking. They pass in DC control currents to manage the electrical generation process. One brush is common, and the other two, in concert with the common one, feed the rotating field for the exciter/utility outlets, and the weld revolving field. Controlling the relatively small amount of current fed through the brushes controls the output from the two stators by controlling their respective rotating fields strength (exciter/utility outlets and weld). Thus, the same brush (the weld rotating field brush) is used whether you are welding AC or DC. The generator makes AC and it is either sent directly to your leads via the selector switch for AC welding or through the diodes to be rectified into DC for DC welding. The welding field brush just feeds in a variable amount of field current to the welding generator to determine whether you have a little or a lot of output weld current. When you turn your current adjustment knob you are varying the field current. So,if it welds on DC but not on AC it HAS to be a switch or connection problem-absolutely everything else is the same. Hope this helps. If you find you don't have about 75 volts, troubleshooting is a bit easier. Just follow the path back from the leads to the weld stator until you find it. If you do have 75 volts, the next step will have to be following the AC weld path while someone welds to see where you're losing the power. Both of these voltage tracing operations are a job for someone with some electrical and safety training. There's plenty of power in there to kill a guy.
                  Last edited by Aeronca41; 10-09-2017, 05:42 AM.

                  Comment


                  • #24
                    Why won't you just try some 6011 or 6013 I have never had 7018 ac run great on ac current, also 7018 don't like to be cold ,old, or damp
                    Last edited by chub380; 10-10-2017, 06:40 PM.

                    Comment


                    • #25

                      have officially tried different brands and flavors of rod. All rods that weld fine on my Lincoln tombstone by not on my TB.

                      Comment

                      Working...
                      X