Announcement

Collapse
No announcement yet.

Multimatic 200 problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • flushcut
    replied
    Thanks guys!

    Leave a comment:


  • mongobird
    replied
    Originally posted by aametalmaster View Post
    That must be why the New Multimatic 215 has an improved display...Bob
    LCD responsivity is driven by phase change of the LCD. Looking at the 215 display and the 200 display, at room temperature, there does not seem to be a difference in temporal (time for phase change) response. The 215 is a color display, but that does not directly impact the responsivity. My guess is that a decision was made, probably for marketing reasons, and possibly for information (user interface) reasons, to utilize a color display. Perhaps someone can compare the two displays in low ambient temperatures and see if there is really a difference.

    The owner's manual for either unit does not specify the thermal environmental specifications, so there is no clue as to whether one has a wider thermal operational range than the other.

    However, the underlying engines are different. With the 215 having the same architecture as the new 211.

    One spec trivia, for example, is that TIG current in the 200 is spec'd to a low of 5 A, whereas the 215 has a low spec of 20 A. Again, the engines are different, and the intended applications were also different at the time of the product inceptions.

    Leave a comment:


  • aametalmaster
    replied
    That must be why the New Multimatic 215 has an improved display...Bob

    Leave a comment:


  • mongobird
    replied
    I used my Multimatic 200 when the ambient temp was 10F this past winter. The LCD was slow to respond, but eventually read stable after a second or two. It did not get "faster" after the machine was used, but consider that it was 10F outside. We're getting nights of low 30's so if you want I can go turn it on some morning when it is cold, and see how it responds without running any welds.

    Leave a comment:


  • xryan
    replied
    Been through hundreds of lbs or wire, 50lbs of rod, 5lbs of tig wire?

    Never had a hiccup. Sorry.

    Leave a comment:


  • aametalmaster
    replied
    Great. I have the 200 and 215 sitting in front of me...Bob

    Leave a comment:


  • flushcut
    replied
    I love mine! I have only run stick and mig with it so far so good, 30lbs of wire and 20lbs of rod.

    Leave a comment:


  • aametalmaster
    replied
    I would say common. But there is only like 2 people on this forum with that machine. I am looking at one but haven't bought it yet...Bob

    Leave a comment:


  • flushcut
    started a topic Multimatic 200 problems

    Multimatic 200 problems

    Howdy gents, I have a multimatic 200 that has a problem with it's LCD display. When it's below 60 degrees or colder the display does not work but once the machine is warm (after several beads) or I take a heat gun to it does it work. Is this a common problem or is it just a finicky LCD? Any input would be appreciated.
Working...
X