Announcement

Collapse
No announcement yet.

Econotig arc problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • cledford
    replied
    Ok sorry for the delay in posting, been crazy busy. I finaly got it to bust out a sick weld then welded a few good welds. Swapped back over to tig and everything works except the gas won't flow and I feel like it had been working before. Wondering if I fried something or if there's a possible simple solution...<br />
    <br />
    I'm glad it's at least welding though.

    Leave a comment:


  • buffumjr
    replied
    As an Econotig owner, I'm VERY interested.

    What's the progress?

    Duaneb55, I'm writing your ID in my notebook. If I have trouble with mine, I'll contact you. So far, all my issues have been newbie issues. We used to say, in Information Technology, "operator headspace". 3/32" rod rocks! TIG works fine. Haven't tried aluminum, yet, but it worked great on stainless!

    I modified mine by buying 20' of #8 power cord, installing crimped connectors, and changing out the cord. Why, oh why does Miller put such toaster size cords on these things?

    Cledford, keep posting. You have my attention.

    Leave a comment:


  • H80N
    replied
    Originally posted by cledford View Post
    @H80N, @duaneb88, Nothing on ac either, haven't tried stick yet. Opened it up and selector switch seems like its contacting good and no black marks or anything on it to indicate being switched under load. I dont have another torch that I know is good but I have a few stingers I use often, I'll have to see if i can get an arc with one. In the meantime any other ideas as to what the issue could be?
    Well then.... by all means attach a stinger and see if you can stick weld with it... both AC and DC

    Leave a comment:


  • cledford
    replied
    @H80N, @duaneb88, Nothing on ac either, haven't tried stick yet. Opened it up and selector switch seems like its contacting good and no black marks or anything on it to indicate being switched under load. I dont have another torch that I know is good but I have a few stingers I use often, I'll have to see if i can get an arc with one. In the meantime any other ideas as to what the issue could be?

    Leave a comment:


  • duaneb55
    replied
    Damaged selector switch contacts makes perfect sense H80N.

    Always start with the basics.
    Last edited by duaneb55; 06-03-2016, 09:56 AM.

    Leave a comment:


  • H80N
    replied
    Originally posted by cledford View Post
    <br />
    <br />
    Yes on the ground.<br />
    <br />
    Yes on the tungsten. Tried 3/32 pure and and 1/16 2% thoriated<br />
    <br />
    Yes its set for tig<br />
    <br />
    I believe thats the correct manual<br />
    <br />
    Serial is KH503785
    OK...

    here is the manual that is correct for that Serial Number KH503785

    https://www.millerwelds.com/files/ow.../O303F_MIL.pdf

    Can you draw a Stick Arc in DC Neg.... if so

    Try it on AC TIG and see if you have HF.....

    If it works fine on AC HF... I might suspect a damaged selector switch... the contacts can get burned if switched under power

    Also try a "Known Good" TIG torch... you may have a damaged torch

    Leave a comment:


  • duaneb55
    replied
    Will it scratch start?

    If it will scratch start but will not initiate an arc across a normal tungsten-to-work gap then I would suspect a failed high voltage transformer T2 that is responsible for starting the arc.

    If T2 has failed it is likely that its capacitor C1 had failed shorted first causing the T2 failure. At least that has been my experience with the Econotig with this type of complaint.

    To test T2, with the machine off and transformer disconnected, check for a primary resistance of less than 1ohm across wires 51 & 52 and for secondary resistance of 6ohms across wires 57 & 43. An OL or 0 meter reading indicates an open winding and thus defective T2.

    Leave a comment:


  • cledford
    replied
    Originally posted by H80N
    <br />
    <br />
    You have a clean solid ground..??<br />
    <br />
    Tungsten ground and prepped..?? Tung type & size..??<br />
    <br />
    Weld Process switch set to TIG..??<br />
    <br />
    is this the correct manual..??<br />
    <br />
    https://www.millerwelds.com/files/ow.../O303V_MIL.pdf<br />
    <br />
    PLS post your serial #
    <br />
    <br />
    Yes on the ground.<br />
    <br />
    Yes on the tungsten. Tried 3/32 pure and and 1/16 2% thoriated<br />
    <br />
    Yes its set for tig<br />
    <br />
    I believe thats the correct manual<br />
    <br />
    Serial is KH503785

    Leave a comment:


  • H80N
    replied
    Originally posted by cledford View Post
    i thought originally that DC- was the polarity to use but it didn't want to arc, not sure why. So i went to + and it gave me sumthin so i just assumed. Any ideas on it not arcing in DC-?
    You have a clean solid ground..??

    Tungsten ground and prepped..?? Tung type & size..??

    Weld Process switch set to TIG..??

    is this the correct manual..??

    https://www.millerwelds.com/files/ow.../O303V_MIL.pdf

    PLS post your serial #

    Leave a comment:


  • cledford
    replied
    i thought originally that DC- was the polarity to use but it didn't want to arc, not sure why. So i went to + and it gave me sumthin so i just assumed. Any ideas on it not arcing in DC-?

    Leave a comment:


  • ryanjones2150
    replied
    How's it running now with it hooked up properly?

    Leave a comment:


  • H80N
    replied
    Originally posted by cledford View Post
    I have a used miller econotig that has some age on it but seems to be in good condition. I have it set for DC positive and welding mild steel and it will arc but doesn't seem to be transferring any heat, it just immediately melts the tungsten. Anybody know what the problem could be?
    YUP...Wrong Polarity

    Try DC Electrode Negative.... Much better....

    Think you will find this TIG Guidebook useful

    https://www.millerwelds.com/~/media/...s/gtawbook.pdf

    Last edited by H80N; 05-31-2016, 11:06 PM.

    Leave a comment:


  • cledford
    started a topic Econotig arc problems

    Econotig arc problems

    I have a used miller econotig that has some age on it but seems to be in good condition. I have it set for DC positive and welding mild steel and it will arc but doesn't seem to be transferring any heat, it just immediately melts the tungsten. Anybody know what the problem could be?
Working...
X