Announcement

Collapse
No announcement yet.

Need help with an older Sync 250

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Need help with an older Sync 250

    I just joined the forum but have been reading on here for a week or so.

    I recently purchased a Syncrowave 250 that needs some work.Here is the back story on the welder and whats its doing.

    The man I purchased it from used it in his home garage, supposedly only had it for a year or two. It worked fine up until a few months ago. He took it into his local shop to have it diagnosed. As it turns out, the PC1 board was the problem. He sent the board out for repair/rebuild to a company in Danville VA that specializes in electronic repairs (i'd be happy to provide the name to anyone via PM, don't want to call out a shop in the open forum). From what he said, all the capacitors were replaced on the board, the repair cost around $450. He installed the board in the machine and it still isn't working right. He told me he talked with a miller tech and the tech thought it to be something in the HF unit being as he had the PC1 repaired but he didn't remember what part the tech told him it might be.

    With power on, the fan runs but the machine will not strike an arc. When in AC mode and the HF switch is on start or continuous you can hear (what I believe to be) the HF transformer buzz for a few seconds then stop. When the pedal is pressed the machine buzzes again but the points are not arcing. I have not hooked up a torch to see if it will scratch start, plan on doing that tonight. I do know the 110v receptacle on the front has power.

    I've switched output to DC (EP and EN) and it wont strike an arc to stick weld either.

    With info I found here, I tested the foot pedal, shows the appropriate ohms loads when the pedal is pressed/released. So the pedal is good.

    I've pulled the covers, PC1 is clean and it is obvious the caps have been replaced. I took some pics of the board, no burned areas or anything that looks out of the ordinary, I'll post the pics later tonight. The rest of the machine is dusty, going to try to get it blown out tonight.

    I did notice that the work side terminal can be wiggled a little bit, not sure if that's normal or not, ground side terminal is solid and doesn't move. There is a small area about the size of a quarter between the work and ground terminals where it looks like the metal melted or someone tried to weld something to the machine, I'll snap a pic of this as well. Previous owner told me the machine was like that when he got it and it had no impact on the machines performance before the board messed up.

    I'm a novice in the welding game, hoping to get this thing up and running so I can start learning TIG.

    Machine is a '93 model, Serial is KD428515.

    ​Thanks in advance.

  • #2
    The price of the board is pretty close to a new board, hmmm. Which Miller still has. When you put the local/remote switch to local, do you have output?"

    Comment


    • #3
      What your likely hearing is CR2 relay buzzing away, or one of the timer relays. Nothing to do with the HF

      Comment


      • #4
        Originally posted by cruizer View Post
        The price of the board is pretty close to a new board, hmmm. Which Miller still has. When you put the local/remote switch to local, do you have output?"
        That struck me as odd also, $450 to swap out a few caps seemed a bit high rather than paying ~$600 for a whole new board. He couldn't find the invoice but said he would send it as soon as he ran across it, seems to be a stand up guy so I don't really believe he was lying about it.

        I tried it on both remote and local. No sparks at the points. IIRC when I tried to light off with a stick it was on local.

        FWIW it sounded like the buzzing was coming from the lower front of the machine but I'll check it again tonight to confirm it is one of the relays.

        Comment


        • #5
          Not going to get HF without a remote. that HF transformer is on the base, it may be leaking, (sparking out the side of it to the frame)

          Comment


          • #6
            I narrowed down the buzzing, its coming from the gas solenoid. It only buzzes when the conductor is set to remote. I don't have the gas line run to the solenoid right now due to not having the fittings on hand to connect it to my tank and torch. Torch is connected straight to the reg and tank.

            I checked on all (AC, DCEP, and DCEN), no arc when set to local or remote. No scratch start and no HF arcing.

            Here are the pics of the board and the area near the terminals I spoke of.





            Comment


            • #7
              Bumping this up and including a pic from the back of the damaged area, going to try to get a better one but this is the best I have been able to do thus far.


              Any other suggestions on trouble shooting this thing?

              Comment


              • #8
                Is that some sort of coil just to the right of the hole? If so, it's toast. The outer 2 or 3 windings are melted together, and maybe more up under the sheet metal that hides the rest of it.

                Comment


                • #9
                  Ummm, that board has NEVER been to a capable repair shop. The Capacitor install, solder joints are hidious. Besides those Caps would not hinder the pulse transformers from firing. (4 square things on the side)

                  Quite likely a board issue, best to shoot it over to PLC.com, explain that the firing circuit is not working.

                  The last pic is kinda dark, though looks like a stabilizer. Maybe shoot us a better picture

                  Comment


                  • #10
                    The last pic(from my manuals parts list) shows to be part number 124 650 (Coil, HF coupling).

                    I felt the soldier job was a bit shabby as well.. I'll check out PLC. I was really hoping the board wasn't the issue being as it was sent out before.

                    Here is a better pic of the coil.. I tried to find it on miller4less but the part number must not be valid anymore.



                    Also, is the site plccenter.com? I searched plc but didnt come up anything.
                    Last edited by Crocket; 05-30-2016, 11:36 PM.

                    Comment


                    • #11
                      Thats not the cause of your problems , so based on what you've told us, it all points to that board being the culprit. Its highly unlikely that board was sent out to any qualified shop. Replacing caps would NOT have been an issue on the pulse transformers firing or not. Possibly erratic, but the unit would have still worked

                      Comment


                      • #12
                        Ok, would that coil need to be replaced as well? I found what looks to be Radwell International inc under the plccenter.com. Is this the correct company I would need to send the board to?

                        Comment


                        • #13
                          Talked with a rep from Radwell, repair estimate on the board is more than I thought it would be but still about half of what a new one would run. May have the board send out tomorrow to see where we are.

                          Cruizer, should i go ahead and try to source a replacement coil for the pic above or should I wait to see what they say about the board?

                          Comment


                          • #14
                            More updates... Board is confirmed to have issues, not sure what exactly the problems are. Almost $400 in repairs. I'll keep you guys updated once I have the work form back.

                            Comment


                            • #15
                              Well folks, I got the board back along with a laundry list of items that were repaired/replaced. Installed it and she runs like a top now.

                              Thanks guys!

                              Comment

                              Working...
                              X