Announcement

Collapse
No announcement yet.

Miller 180sd weak arc

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • H80N
    replied
    Originally posted by 69shoveled View Post
    Does anybody know of a good source for board repair? I don't want to send it out again and have it not work.
    PLC Center has a pretty good reputation..

    http://www.plccenter.com/

    Leave a comment:


  • 69shoveled
    replied
    Does anybody know of a good source for board repair? I don't want to send it out again and have it not work.

    Leave a comment:


  • ryanjones2150
    replied
    no kidding. At least they're giving you your money back. Maybe they let one of the interns work on it or something.

    Leave a comment:


  • 69shoveled
    replied
    That's a really good question. Put pink marks on some of the chips & cleaned the board? Called them today told them board still don't work want a refund. Said that they would issue me a refund.
    I don't know how you could miss a missing resistor if that's what you supposibly specialize in? Very aggravating.

    Leave a comment:


  • ryanjones2150
    replied
    so what did they do for your $320 besides ship the board back to you?

    Leave a comment:


  • 69shoveled
    replied

    Leave a comment:


  • 69shoveled
    replied
    Pulled board out of welder at work put it in my welder it worked. Inspected the board and resistor R77 was missing on mine. Gem electronics out of Davie Florida claims they repaired my board but they did not. Paid them 320$ do not send anything to these jokers.
    I contacted Miller and they gave me the specs on the correct resistor. Have one on the way and in process of getting my money back. Will update when new resistor is installed.

    Leave a comment:


  • 69shoveled
    replied
    Had board repaired still the same weak erratic arc. Could the Hall sensor and board been bad at the same time? Or they screwed me on the board repair?

    Leave a comment:


  • 69shoveled
    replied
    Shipped board out today to be repaired. Will update when I get it back.

    Leave a comment:


  • 69shoveled
    replied
    Was taken out of an identicle machine from work.

    Leave a comment:


  • cruizer
    replied
    well then your known good hall, either wasnt rated for this machine, or was no good to begin with. cant put any ole hall on it....

    Leave a comment:


  • 69shoveled
    replied
    Put a known good hall sensor in it same problem real irratic pulsing then it will try to tig but nowhere near hot enough- I unhooked hall sensor and it welded wide open burnt my tungsten off.

    Leave a comment:


  • H80N
    replied
    Originally posted by 69shoveled View Post
    I contacted Miller and they said unplug the hall sensor and see if it welds wide open. If it does I was unclear if it means it's not the switch or if it is? Thank you guys for the help. who is Digikey?
    digikey electronics

    http://www.digikey.com/?WT.srch=1

    Leave a comment:


  • 69shoveled
    replied
    I contacted Miller and they said unplug the hall sensor and see if it welds wide open. If it does I was unclear if it means it's not the switch or if it is? Thank you guys for the help. who is Digikey?
    Last edited by 69shoveled; 04-28-2016, 11:26 AM.

    Leave a comment:


  • cruizer
    replied
    Yep Hall / LEM is bad, merely get the part # off it and get another from Digikey...

    Leave a comment:

Working...
X