Announcement

Collapse
No announcement yet.

Trailblazer 44d no arc

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Trailblazer 44d no arc

    Looking at buying a trailblazer 44d off of a guy but went to look at the machine and it had appropriate power to all the outlets but nothing (no voltage reading st all) at the output post for the torch. Thought i was going to get a good deal but i dont want to buy a money pit. Any ideas on what this could be or experience with the same sort of situation?

  • #2
    Welcome, cledford! Do you have the serial number for the machine? That will allow the wizards here to look up the right manual. I suspect this is a pretty broad set of possibilities. Might be worth looking inside and see if anything looks burned, loose, disconnected, etc.

    Comment


    • #3
      @Aeronca41<br />
      I do not have the serial number, however i can try to get the guy selling the machine to get it for me and get back to you on that. I did look inside and nothing looked to be burned and everything seemed to have a tight connection. I'm thinking maybe its a board in there somewhere that has stopped working for whatever reason, and I feel like that could quickly exceed the cost of the machine.

      Comment


      • #4
        I'm not one of the experts-Cruizer is our top wizard and there are a lot of other very knowledgeable people. Always need the ser no to look up the diagrams.
        Not to talk down to you but are you sure all the controls are in the right positions ? Remote amp control and process switches ? Polarity switch solidly in a detent? Did you try working the Coarse and fine amp controls back and forth a few times to be sure they're not corroded? Just some ideas while waiting for an expert.

        Comment


        • #5
          I'd avoid this machine, unless it was free, even then. I'd think hard about it, and I repair machines for a living....

          Comment


          • #6
            Didn't think about the remote, that could very well be it since it is set up to tig. Played with the polarity and both adjustments all that seemed good. The engine runs great, wich is a plus but foesnt help the problem. The reason I would like to figure it out is because it comes on a large trailer with very long 100'+ leads for ground and both tig and electrode. And many other extras for a price that seems very reasonable price. Just wish I knew what the arc problem is. But the remote seems to definitely be a posibility

            Comment


            • #7
              @cruizer<br />
              it actually might as well be free considering what else comes with the package deal.

              Comment


              • #8
                Consider carefully that if it's no good you still get your value from the package deal. Cruizer knows his stuff.

                Comment


                • #9
                  Decided to get the rig. It's at home but I can't seem to find the serial #. Any hints?

                  Comment

                  Working...
                  X