Announcement

Collapse
No announcement yet.

xmt350 problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • cruizer
    replied
    What I get most of the rental firms to do is tighten and red Lock Tite, those jam nuts from new. Somewhat less overall problems

    Leave a comment:


  • jd-11
    replied
    I checked today and found the jam nut loose that tightens the washer with the 2wires. I haven't got to test it yet.

    Leave a comment:


  • jd-11
    replied
    thank you, I will pull the cover and check the nuts. Can you explain to me why this is happening after I air arc and not when I just turn it on?

    Leave a comment:


  • cruizer
    replied
    Don't turn the local control past 3/4 to allow the XMT more control. You will also want to remove the top cover and tighten the nuts behind the output studs as they tend to loosen off with extreme heat. If they do loosen, the long winding on the left side WILL break.

    Leave a comment:


  • jd-11
    started a topic xmt350 problems

    xmt350 problems

    Hello, I have an xmt350. The last 2 times that I have air arced with it at 325 amps, then went to weld once was with stick 3/32 7018 at 103amps and once was with an LN25 .045 outershield wire at 25.4 volts. With the wire it was melting the wire to the tip almost instantly and with the stick it was extremely hot. I almost went through a backhoe bucket in seconds. I looked at the settings on the machine and the voltage side would read 4. I shut down the machine and used a different machine to finish my task. A few days later I stick welded with the same machine and it worked fine. Then several days later I air arced again then went to weld and it was messed up again. Any help would be appreciated.

    Ser# LF89929
Working...
X