Announcement

Collapse
No announcement yet.

Spectrum 2050

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • wb5jhy
    replied
    no transfer arc

    The most likely would be the ground connection. I just cut up some old and very rusty tractor impliments last weekend and had to actually grind through rust to get a good enough ground. Just one of the unmentioned handicaps with using plasma. As stated above, a drop in air pressure when you pull the trigger could cause a drop out. Make sure your air supply hose to large enough to not cause a pressure drop below the "green zone" on the pressure gage. Lastly, check the assembly of the consumables on the torch.

    Good luck. Let us know what you find.

    Leave a comment:


  • cruizer
    replied
    Could be lots of different things, Air presssure, or air presure sensor, maybe a blown Auxillary board, or most likely a blown IGBT down line from the Auxillary board if it shuts down after pilot.

    Leave a comment:


  • timw
    replied
    I have the 625 and I also say it's your ground.

    Leave a comment:


  • Slag
    replied
    Mine does that when I forget the ground clamp. Takes me several attempts of "what the heck?" then I proceed to call myself choice names, clamp on the ground and things are good again.

    Leave a comment:


  • Scott V
    replied
    Originally posted by mlicoasty
    I got a Spectrum 2050 plasma cutter. For some reason it won't work. All I am getting is the pilot then it just cuts out. I can't get any spark. The torch has never been used and I have a new air compressor system with oil and water seperators at the regulator. If anybody has any ideas please let me know I am at my wits end with this @#$% machine.
    What is the air flow set at on the machine while purging?
    That will stop the arc. Ground wire on and clean?

    Leave a comment:


  • mlicoasty
    started a topic Spectrum 2050

    Spectrum 2050

    I got a Spectrum 2050 plasma cutter. For some reason it won't work. All I am getting is the pilot then it just cuts out. I can't get any spark. The torch has never been used and I have a new air compressor system with oil and water seperators at the regulator. If anybody has any ideas please let me know I am at my wits end with this @#$% machine.
Working...
X