Announcement

Collapse
No announcement yet.

millermatic 300 issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • millermatic 300 issue

    I have a millermatic 300 mig welder and everything seems to run fine, except when you go to actually weld it will arc and then start curving the wire like it has a bad ground or something and all the repair shop are about a 2 month lead time has anyone experienced this

  • #2
    Originally posted by jesco012 View Post
    I have a millermatic 300 mig welder and everything seems to run fine, except when you go to actually weld it will arc and then start curving the wire like it has a bad ground or something and all the repair shop are about a 2 month lead time has anyone experienced this
    Could you post the serial number PLS....
    There are many versions of the MM300...

    https://www.millerwelds.com/support/manuals-and-parts

    Last edited by H80N; 11-17-2015, 02:01 PM.
    .

    *******************************************
    The more you know, The better you know, How little you know

    “The bitterness of poor quality remains long after the sweetness of low price is forgotten”

    Buy the best tools you can afford.. Learn to use them to the best of your ability.. and take care of them...

    My Blue Stuff:
    Dynasty 350DX Tigrunner
    Dynasty 200DX
    Millermatic 350P w/25ft Alumapro & 30A
    Millermatic 200

    TONS of Non-Blue Equip, plus CNC Mill, Lathes & a Plasmacam w/ PowerMax-1000

    Comment


    • #3
      Well, either you lost a input phase,as it's a 3 phase machine, or your gun handle has come away from the cable conduit.

      Comment


      • #4
        so I took the lead and handle apart didn't notice anything and just made sure it was all put back together turn on the machine and it works fine. Is it possible that the input phase is going out and is cutting on and off or would it just go completely out. Thanks for the help.

        Comment

        Working...
        X