Announcement

Collapse
No announcement yet.

Start Switch - Replacement - Help

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • nfinch86
    replied
    Ammeter to Switch was the wire that was done like dinner...... Lol .

    Norm

    Leave a comment:


  • cruizer
    replied
    It's always the connection between the firewall and switch. And or the fuse, near the starter

    Leave a comment:


  • nfinch86
    replied
    Thanks , Yes I'm extremely happy & relieved !
    One switch & one unknown fried wire could have put me out of business .
    I could have sent it to a welder- tech for big bucks , glad it didn't come to that !

    Back on the road again .

    Norm

    Leave a comment:


  • H80N
    replied
    Glad to hear it....

    Leave a comment:


  • nfinch86
    replied
    All Fixed !!!!!!!!
    My Son put a test light on it & found one burned wire , nothing external to indicate it was fried .
    Replaced that one wire & it fired right up !

    Success , Yes !!!!!

    Norm

    Leave a comment:


  • nfinch86
    replied
    Thankyou Very much - That will really help !!!!!!!!!

    Norm

    Leave a comment:


  • H80N
    replied
    And here is good reference for the rest of the schematic symbols...

    http://rapidtables.com/electric/electrical_symbols.htm

    Leave a comment:


  • H80N
    replied
    Originally posted by nfinch86 View Post
    Yes, So does mine.
    I can't see any fuses , but I'm not an expert at reading schematics.
    I'm hoping my son will be able to help me today .
    Maybe this will help... Schematic fuse symbol..

    Leave a comment:


  • nfinch86
    replied
    Yes, So does mine.
    I can't see any fuses , but I'm not an expert at reading schematics.
    I'm hoping my son will be able to help me today .

    Leave a comment:


  • H80N
    replied
    Originally posted by nfinch86 View Post
    I have the manual - It's No help .
    The ones I looked at have the schematics in the back....

    Leave a comment:


  • nfinch86
    replied
    I have the manual - It's No help .

    Leave a comment:


  • H80N
    replied
    Did you download and READ the manual..??
    Last edited by H80N; 10-11-2015, 07:35 AM.

    Leave a comment:


  • nfinch86
    replied
    Yes The wires are on correctly - I took one off at a time as I replaced each one.
    As far as power coming to & from the switch - No I have not done that, but will today.
    I'm going to my son's place today for Thanksgiving - he's an auto- tech, so he should have a better idea than me .

    I'll report his findings later today.

    Thanks for the help !!!!!!!!

    Norm

    Leave a comment:


  • MMW
    replied
    Are you sure the wires are on correctly? Do you have a manual with a wiring diagram? Have you traced the wires looking for a fuse? Have you checked to see if you have power coming into the switch & out of the switch when in the proper position? Power to the starter?
    Last edited by MMW; 10-11-2015, 05:06 AM.

    Leave a comment:


  • nfinch86
    replied
    No Ryan, When the switch first broke, I tried it - that's when there was a Little Smoke.
    I disconnected the battery right away.

    There are No Burned Wires !

    I installed the New Switch & Nothing - no sound, no nothing .

    Norm

    Leave a comment:

Working...
X