Announcement

Collapse
No announcement yet.

Syncrowave 250 won't start.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mike W
    replied
    Thanks for the reply. I just looked at the manual and this model does not have any fuses. It just has the 15 amp circuit breaker on the front. It is at work and I won't be back until tuesday.

    Leave a comment:


  • cruizer
    replied
    You know, you have 2 fuses INSIDE your machine ehhh. Disconnect your power and pull the top cover off Just to the right and down from the center suport you'll find them. It's quite likely that you've lost one of your small control bridge rectifiers, or a wire has come off.

    Just a thought...

    Leave a comment:


  • Mike W
    started a topic Syncrowave 250 won't start.

    Syncrowave 250 won't start.

    This one is about a year and a half old. I did a short bead and then set up some new material. When I pushed the pedal, there was no gas flow and no high freq. Later on it just started working and was fine. The next day I did one bead and the samething happened. I never did get it to work after that.

    All the switches and lights work ok. I plugged in a hand control to make sure the foot control wasn't the problem. The little breaker for the high freq and the outlet is ok. Water is flowing. I was only welding with 30 amps so heat is not a problem. I popped off the top and checked all the plugs. I tried a lift arc start and no go. So now I am thinking it is a problem with the main circuit board. Has anyone else had this happen?
Working...
X