Announcement

Collapse
No announcement yet.

Need repair advice on Dynasty 200DX

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Need repair advice on Dynasty 200DX

    My Dynasty was manufactured in 06 and I have owned it since 08. Recently it has started to act up after about 3 min of use. I took it in to Matheson Electric to have it diagnosed. The tech there told me that the inverter control card (board) part # 207822 has failed. New cost of board $1250 plus an hour labor. On top of this it may need a Boost control card part #200841. I was told the first card has to be replaced before it can be tested further. I did not get a price on the Boost control card as I was sickened by the thought of the first quote of around $1350. As I was searching for the #207822 I came across a replacement part SKU of #230187. Does anyone know if this is an improved board that has a better design than the previous # or is it even compatible? Or should I just cut my losses and go with a new machine?

  • #2
    Originally posted by gearguy View Post
    My Dynasty was manufactured in 06 and I have owned it since 08. Recently it has started to act up after about 3 min of use. I took it in to Matheson Electric to have it diagnosed. The tech there told me that the inverter control card (board) part # 207822 has failed. New cost of board $1250 plus an hour labor. On top of this it may need a Boost control card part #200841. I was told the first card has to be replaced before it can be tested further. I did not get a price on the Boost control card as I was sickened by the thought of the first quote of around $1350. As I was searching for the #207822 I came across a replacement part SKU of #230187. Does anyone know if this is an improved board that has a better design than the previous # or is it even compatible? Or should I just cut my losses and go with a new machine?
    I would be tempted to release and reseat all the connectors...

    loosen and retighten the dinse connectors

    snug all the boards down..

    and do a reset to factory defaults just for good measure..

    then see how it behaves.............
    .

    *******************************************
    The more you know, The better you know, How little you know

    “The bitterness of poor quality remains long after the sweetness of low price is forgotten”

    Buy the best tools you can afford.. Learn to use them to the best of your ability.. and take care of them...

    My Blue Stuff:
    Dynasty 350DX Tigrunner
    Dynasty 200DX
    Millermatic 350P w/25ft Alumapro & 30A
    Millermatic 200

    TONS of Non-Blue Equip, plus CNC Mill, Lathes & a Plasmacam w/ PowerMax-1000

    Comment


    • #3
      I'll try that tomorrow. How do you do the factory reset? The cover was off the machine when I picked it up. I would hope that they tried that already. I know they have a machine to load test it and that was done.

      Comment


      • #4
        Actually I found instructions in the service manual so thanks. I'll update tomorrow on what happens.

        Comment


        • #5
          Go to section "5-17. Resetting Unit To Factory Default Settings"

          in your owners manual..

          if you do not have one... it can be downloaded here

          http://www.millerwelds.com/service/ownersmanuals.php

          just plug in your serial number..

          EDIT: See you found it while I was typing... but will leave this up for the benefit of others later
          Last edited by H80N; 08-19-2015, 08:52 PM.
          .

          *******************************************
          The more you know, The better you know, How little you know

          “The bitterness of poor quality remains long after the sweetness of low price is forgotten”

          Buy the best tools you can afford.. Learn to use them to the best of your ability.. and take care of them...

          My Blue Stuff:
          Dynasty 350DX Tigrunner
          Dynasty 200DX
          Millermatic 350P w/25ft Alumapro & 30A
          Millermatic 200

          TONS of Non-Blue Equip, plus CNC Mill, Lathes & a Plasmacam w/ PowerMax-1000

          Comment


          • #6
            Well I didn't have anything better to do so went out and reseated the boards, connectors to the boards and the backed off and retightened the terminals that were bolted on and still no go. The inverter board looks good with no burn marks or obvious broken connections but somehow it is faulty.

            Comment


            • #7
              Originally posted by gearguy View Post
              Well I didn't have anything better to do so went out and reseated the boards, connectors to the boards and the backed off and retightened the terminals that were bolted on and still no go. The inverter board looks good with no burn marks or obvious broken connections but somehow it is faulty.
              Could you describe the symptoms...??

              CRUIZER is our resident repair wizard... hope he sees this thread
              .

              *******************************************
              The more you know, The better you know, How little you know

              “The bitterness of poor quality remains long after the sweetness of low price is forgotten”

              Buy the best tools you can afford.. Learn to use them to the best of your ability.. and take care of them...

              My Blue Stuff:
              Dynasty 350DX Tigrunner
              Dynasty 200DX
              Millermatic 350P w/25ft Alumapro & 30A
              Millermatic 200

              TONS of Non-Blue Equip, plus CNC Mill, Lathes & a Plasmacam w/ PowerMax-1000

              Comment


              • #8
                It started out as it worked fine for 30 minutes then no arc in AC or DC. Then gradually the time that it took to malfunction became less and less. If I let it sit a while it would function properly for a few minutes. Before I took it in it only would arc for maybe 15 seconds. Now that I picked it up from getting it tested no arc at all. The solenoid kicks the gas on but no arc. Machine sounds normal as in full of bees is my best description. I was just going to purchase a new board but if you guys don't mind helping me verify that it is the inverter board I really appreciate it. I have a UEI Ohm/volt meter but don't know where to test things.

                Comment


                • #9
                  So a little more info. When it does act up the display goes through the boot menu whenever the foot control is depressed. The gas solenoid only allows gas to flow for a second each time.

                  Comment


                  • #10
                    Reading these stories about the issues with the 200DX make me very fearful of this machine.

                    Comment


                    • #11
                      Any ideas anyone?

                      Comment


                      • #12
                        Bump...

                        Originally posted by gearguy View Post
                        Any ideas anyone?
                        Usually CRUIZER will check in pretty often and gives excellent troubleshooting advice

                        Maybe if we bump this he will see it...
                        .

                        *******************************************
                        The more you know, The better you know, How little you know

                        “The bitterness of poor quality remains long after the sweetness of low price is forgotten”

                        Buy the best tools you can afford.. Learn to use them to the best of your ability.. and take care of them...

                        My Blue Stuff:
                        Dynasty 350DX Tigrunner
                        Dynasty 200DX
                        Millermatic 350P w/25ft Alumapro & 30A
                        Millermatic 200

                        TONS of Non-Blue Equip, plus CNC Mill, Lathes & a Plasmacam w/ PowerMax-1000

                        Comment


                        • #13
                          I've been thinking of taking it somewhere else that can give me a solid quote instead of saying we need to fix this first and then see if it needs something else. According to Miller that's how it's suppose to be done. Unless someone here can help me trouble shoot.

                          Comment


                          • #14
                            Originally posted by gearguy View Post
                            I've been thinking of taking it somewhere else that can give me a solid quote instead of saying we need to fix this first and then see if it needs something else. According to Miller that's how it's suppose to be done. Unless someone here can help me trouble shoot.
                            You might contact Miller TIG support and explain your situation

                            here is their main number they can connect you

                            Phone: 920-734-9821

                            Here is their contact page

                            https://www.millerwelds.com/service/contactus.html

                            .

                            *******************************************
                            The more you know, The better you know, How little you know

                            “The bitterness of poor quality remains long after the sweetness of low price is forgotten”

                            Buy the best tools you can afford.. Learn to use them to the best of your ability.. and take care of them...

                            My Blue Stuff:
                            Dynasty 350DX Tigrunner
                            Dynasty 200DX
                            Millermatic 350P w/25ft Alumapro & 30A
                            Millermatic 200

                            TONS of Non-Blue Equip, plus CNC Mill, Lathes & a Plasmacam w/ PowerMax-1000

                            Comment


                            • #15
                              Thanks H80N. I have been speaking with one of their techs but they are not very forthcoming with information.

                              Comment

                              Working...
                              X