Announcement

Collapse
No announcement yet.

Aluminum/Dynasty

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Bob Sigmon
    replied
    I have definately had a few droops in my early practice. Now I'm focusing on learning when to stop due to heat buildup and of course learning to restart and keep the bead looking nice. I have had some dismal failures but I am starting to see more successes.

    Thanks for all your help (Not just Hawk, but everyone that contributes to the board)

    Bob Sigmon

    Leave a comment:


  • HAWK
    replied
    Bob,

    It is not always as easy as it sounds to inrease your travel speed. Sometimes you have to let up on the pedal or even stop for a cooling session. When I was first trying to get my travel speed up the aluminum would get so hot that I could just push the filler rod as fast as I could and it just kept disappearing. When I finished the beads were wide and nearly flat. Once I stopped and checked the underside of the plate I found it drooping badly. There is always that learning curve and nothing overcomes it like practice.

    Leave a comment:


  • Wheels
    replied
    I remember before I learned to increase travel speed with mig aluminum I would hear a SPLAT and get a good look at my boots through the big hole.

    Leave a comment:


  • Bob Sigmon
    replied
    Bob, IN RESPONSE TO THE ABOVE QUOTE FROM YOUR EARLIER POST.

    I don't usually let off the pedal as the the aluminum gets hot. I just run a heck of a lot faster. You are right. You either have to let up on the amptrol or really pick up the speed after a bit when the base aluminum starts heating up. It has superior thermal conductivity!
    Hawk,

    I wish that I could work faster but I'm just slowly building my speed feed the filler. Hence, I let up on the pedal. I read all your posts and really appreciate all of the info that you and the other great welders put out here. I have really been trying to soak up all your posts on the Dynasty. It is really a great machine and I doubt that I'll outgrow the capabilities of the fantastic piece of equipment.

    Thanks,

    Bob Sigmon

    Leave a comment:


  • Wheels
    replied
    No offence taken at all . I should be ashamed fo taking up everyones time nit-picking. But as I said before, I have tried my mig regulator with the same result, turn off tank, zero within 30seconds. Both regulators hold pressure hooked to the mig with the same bottle.

    Leave a comment:


  • Paul Seaman
    replied
    Wheels: Try soapy water in a spray bottle work one fitting at a time till you get to the power supply, if no leak then maybe its a valve inside, not probable but possible. I didn't mean to sound old mother hubbard I do appologize. Good luck

    Leave a comment:


  • HAWK
    replied
    To all leaking posts:

    I am with Andy in that it may the regulator set. I use a flow meter and never turn my gas off until the bottle is empty and needs to be swapped for a fresh fill. I do turn off my Dynasty at the end of the evening, but the tanks stay wide open less a slight turn back once the tank valve seats all the way open. I turn it back toward the close direction just a bit to avoid damaging the internal valve seat. That is just a pet peeve of mine.

    Leave a comment:


  • Wheels
    replied
    PJ
    I always turn off my bottle if I`m taking a long break from work, but I`m my guages are dropping to zero in less than 30 seconds. Can`t find the leak.

    Leave a comment:


  • HAWK
    replied

    Wheels,

    I have found, in my very limited experience, that I have to back the foot pedal off quite a bit by the end of a run. The heat really builds up in the aluminum and the bead will widen and flatten out pretty quick.




    Bob, IN RESPONSE TO THE ABOVE QUOTE FROM YOUR EARLIER POST.

    I don't usually let off the pedal as the the aluminum gets hot. I just run a heck of a lot faster. You are right. You either have to let up on the amptrol or really pick up the speed after a bit when the base aluminum starts heating up. It has superior thermal conductivity!

    Leave a comment:


  • Paul Seaman
    replied
    An ounce of prevention is worth a pound of cure: I always turn off the gas when done, its cheaper on the pocketbook if you should develope a leak. If you do this every time then when the machine gets old you don't find an empty tank when the supply is closed.

    Leave a comment:


  • Bob Sigmon
    replied
    My Dynasty has a verrrry slow leak. It takes overnight to see the drop. I just turn my gas off at the end of the day and haven't had any significant loss (other than my bad practive welds).

    Bob Sigmon

    Leave a comment:


  • Wheels
    replied
    Andy

    Both of my regulators leak down when hooked to the Dynasty, and both hold pressure when hooked to the mig.Makes me think either a hose is leaking and I have yet to find it or I have an internal leak.
    Anyhow i`m sure its no biggie.

    Thanks Mike

    Leave a comment:


  • ASKANDY
    replied
    Maybe it's not a problem at all. I use the flowmeters instead of the 2 dial regulator so maybe it's just the nature of that regulator. I'll try to hunt one of the others up and test it.

    a-

    Leave a comment:


  • t500
    replied
    I also have a Dynasty 200DX with the same problems with the leaking argon. I haven't done any leak detection yet, but would be interested to hear your findings. For now i turn the gas off as soon as i am done. Hopefully I'll get around to checking mine this weekend.

    Leave a comment:


  • Wheels
    replied
    Andy

    I pressured it up and used leak detector on it and found no external leaks. Put the mig regulator on and it dropped from 500psi to zip in less than 30seconds. I hate wasting gas , the wife says I do enough of that already .

    Thanks Mike

    Leave a comment:

Working...
X