Announcement

Collapse
No announcement yet.

dynasty 350 coolmate 3.5 popping 10 amp breaker

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • H80N
    replied
    Originally posted by k5brother454 View Post
    oh yes i love this new machine its great and yea I'm heavy into the custom fab/ motorsports i will have to post some pics of my projects i have going on!
    Yes... pls do....

    and start a thread on them in the "Motorsports" section...

    always great to see what folks are building..
    Last edited by H80N; 08-19-2015, 08:21 PM.

    Leave a comment:


  • k5brother454
    replied
    oh yes i love this new machine its great and yea I'm heavy into the custom fab/ motorsports i will have to post some pics of my projects i have going on!

    Leave a comment:


  • H80N
    replied
    Originally posted by k5brother454 View Post
    thanks for all the responses i took a side cover off the cooler and the pump was just stiff from sitting for so long, turned it by hand and its running great!
    Glad you got it sorted out...

    The Dynasty 350 is truly a superb machine...

    Looking forward to seeing posts of your upcoming projects...

    Does the "454" in your Sig... hint that we might see some automotive projects in the Motorsports area in the future...??...

    You might want to look at some of what real artists can do with a Dyn-350

    John Marcella:

    https://www.youtube.com/watch?v=jcU0hMDD4hM

    Chris Razor:

    https://www.youtube.com/watch?v=ohuoWdZ7fW0

    Last edited by H80N; 08-19-2015, 07:58 AM.

    Leave a comment:


  • ryanjones2150
    replied
    dynasty 350 coolmate 3.5 popping 10 amp breaker

    Another satisfied customer...way to go forum.

    Leave a comment:


  • k5brother454
    replied
    thanks for all the responses i took a side cover off the cooler and the pump was just stiff from sitting for so long, turned it by hand and its running great!

    Leave a comment:


  • griff01
    replied
    Originally posted by k5brother454 View Post
    looking for some help here i have a new dynasty 350 i bought second hand from a guy who never hooked it up it was just sitting in his garage for a few years. anyways it powers on fine but the coolmate pops the 10 amp breaker after only a few seconds , any idea on why is keeps popping the breaker? thanks.
    Only a guess since I don't have the machine here but my hunch is the pump shaft is stuck.


    Griff

    Leave a comment:


  • H80N
    replied
    Originally posted by k5brother454 View Post
    doesn't seem to have any pinched hoses and its the 10 amp breaker on the top rear or the welder where there is 2 110 volt plugs
    Sounds like the pump/motor is locked up..

    here are the manuals

    http://www.millerwelds.com/om/o231313p_mil.pdf

    http://www.millerwelds.com/om/t231313g_pt_mil.pdf

    Leave a comment:


  • k5brother454
    replied
    doesn't seem to have any pinched hoses and its the 10 amp breaker on the top rear or the welder where there is 2 110 volt plugs

    Leave a comment:


  • H80N
    replied
    Originally posted by k5brother454 View Post
    yea just filled it up with 3 gallons its all brand new
    pinched hose??

    is the cooler plugged into the back of the welder or otherwise on the same breaker as the welder??
    Last edited by H80N; 08-17-2015, 06:34 PM.

    Leave a comment:


  • k5brother454
    replied
    yea just filled it up with 3 gallons its all brand new

    Leave a comment:


  • H80N
    replied
    Originally posted by k5brother454 View Post
    looking for some help here i have a new dynasty 350 i bought second hand from a guy who never hooked it up it was just sitting in his garage for a few years. anyways it powers on fine but the coolmate pops the 10 amp breaker after only a few seconds , any idea on why is keeps popping the breaker? thanks.
    Did you check the coolant level..??

    a dry pump will kick the breaker .... and probably damage the procon pump..

    Leave a comment:


  • k5brother454
    started a topic dynasty 350 coolmate 3.5 popping 10 amp breaker

    dynasty 350 coolmate 3.5 popping 10 amp breaker

    looking for some help here i have a new dynasty 350 i bought second hand from a guy who never hooked it up it was just sitting in his garage for a few years. anyways it powers on fine but the coolmate pops the 10 amp breaker after only a few seconds , any idea on why is keeps popping the breaker? thanks.
Working...
X