Announcement

Collapse
No announcement yet.

Miller 330A/BP Problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • kmac651
    replied
    Originally posted by MinnesotaDave View Post
    First thing I would check are the contacts on the range selector. Mine will give me no power in the midrange sometimes, if I just move it back and forth a couple times it will make a connection and work. I've not taken it apart to find out why - but I suspect my contacts are either worn or dirty. My AC/DC selector does the same thing sometimes - but it's a 1963 machine so a few quirks don't bother me Here's a tech manual I have stored in a drop box: https://www.dropbox.com/sh/7ijbgx67wuq6ivd/sYvAlvq_LC
    I greatly appreciate the help!!!! I'm going to check out the tech manual and see if I can find the problem. Thank you again very much!!!!

    Leave a comment:


  • MinnesotaDave
    replied
    First thing I would check are the contacts on the range selector.

    Mine will give me no power in the midrange sometimes, if I just move it back and forth a couple times it will make a connection and work.

    I've not taken it apart to find out why - but I suspect my contacts are either worn or dirty.

    My AC/DC selector does the same thing sometimes - but it's a 1963 machine so a few quirks don't bother me

    Here's a tech manual I have stored in a drop box:
    https://www.dropbox.com/sh/7ijbgx67wuq6ivd/sYvAlvq_LC

    Leave a comment:


  • kmac651
    started a topic Miller 330A/BP Problems

    Miller 330A/BP Problems

    Having issues with my 330A/BP on the low and medium amp range DC stick. I can weld ok on the high amp range setting on DC stick. I can't start a weld in either low or medium DC stick. I tried the use the tig and that would only work on the high amp range also. Wire connections all look good. I have all new leads with a new clamp on the ground and a new stinger. Nothing obvious looks wrong. I bought it a couple years ago but have only used it for heavy duty repairs up until now. Now I have a need for the low and medium amp range settings Help!!!!!!! Thank you for any Help I Can Get!!!!!!!
Working...
X