Announcement

Collapse
No announcement yet.

Dynasty 700

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • cruizer
    replied
    The above poster is quite correct, hlp 21 always means that you've hit the pedal before the machines software has loaded. So either a bad pedal or its connector to the machine was not wiggled in all the way.

    Changing boards probably did absolutely nothing. You will have to pull a reset and check the pedal's micro switch as well as, undo the plastic plug and check for damaged wires

    Leave a comment:


  • shovelon
    replied
    I believe I have had a "Help 21", or it could have been a "help 10, a few times on my Dynasty200. It was caused by the finger controller switched on before I powered up.

    Could be worth a try switching out the pedal for a while. Sometimes the belt jumps a tooth inside and wreaks havoc.
    Last edited by shovelon; 05-13-2015, 08:33 PM.

    Leave a comment:


  • H80N
    replied
    Originally posted by saulo saavedra View Post
    Thank you for your help, we barely use this welder and a local shop say probably is why is giving you so much trouble! is that true?I will try to reset it to factory settings.Thanks
    A clean reset to factory defaults will erase any conflicting settings that could be scrambling it's brain... then set it up as per the video for what you are welding...

    just a hunch... pretty common on these Dynasties..

    there are so many options available.. that it is easy to paint yourself into a corner..

    A LOT of Options... here is the Data Sheet..

    http://www.millerwelds.com/pdf/spec_sheets/AD5-0.pdf
    Last edited by H80N; 05-13-2015, 01:04 PM.

    Leave a comment:


  • saulo saavedra
    replied
    Dynasty 700

    Thank you for your help, we barely use this welder and a local shop say probably is why is giving you so much trouble! is that true?I will try to reset it to factory settings.Thanks

    Leave a comment:


  • H80N
    replied
    Saulo

    you are only about 50 miles away from Shovelon's shop in Chatsworth...

    Still betting on a default reset ... THEN set it up...

    https://www.youtube.com/watch?v=I73S7fBStsY

    Leave a comment:


  • saulo saavedra
    replied
    Some of the problems

    This are some of the problems:When starting to weld, the electrode would be energized without the pedal being depressed.The display would then show “HELP – 21”, & welder would not work. During the early Stages of problem, turning the machine off/on a couple of times would return things to normal & would work fine for a short period, then, “HELP-21” would come back to display,& mach. won`t work after that. Have had local repair shops involved. Pedal checks ok. They have replaced a couple of electronic (circuit boards) suggested by Miller factory.I still will look for the paper work listing repairs completed and then post them here.Help 21 DisplayIndicates voltage or current feedback hasbeen detected with contactor off. Contact aFactory Authorized Service Agent if thisdisplay is shown.
    Last edited by saulo saavedra; 05-13-2015, 11:55 AM.

    Leave a comment:


  • saulo saavedra
    replied
    Dynasty 700

    Thanks for your prompt response, I'm looking for the paper work of what they did to the welder the three times we have send it for repair.

    We are located in Buena Park California.

    Here picture of the tag:




    Last edited by saulo saavedra; 05-13-2015, 11:00 AM.

    Leave a comment:


  • H80N
    replied
    Reset to Default settings..

    .... most of the Dynasty probs that I have heard of were operator error...

    they are a pretty complex machine with a lot of settings options.. easy to get the settings scrambled..... not to mention ... that they weld differently than a transformer machine like a Sync..

    May just need to be reset to factory defaults and start again...

    BUT as requested... how about a serial number and a description of the problems you are encountering..???
    Last edited by H80N; 05-12-2015, 02:35 PM.

    Leave a comment:


  • cruizer
    replied
    Maybe you could post the problems you've had with it, as we are not mind readers. Plus where you are located, maybe a serial# to check on updates

    Leave a comment:


  • shovelon
    replied
    Yep, I have one. Works fine.

    What problems are you having? Is it still under warranty?

    Leave a comment:


  • saulo saavedra
    started a topic Dynasty 700

    Dynasty 700

    Good morning, I'm new to the forum, I wonder if anyone has a dynaty 700 welder and if you experienced problems, we bought this brand new welder and almost did not use because has given us so many problems. I would appreciate if someone had a problem with this welder to share it with me.Thanks
Working...
X