Announcement

Collapse
No announcement yet.

**Need some help** Spectrum 375 w/XT30C torch

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Guest's Avatar
    Guest replied
    Originally posted by Jay Gadsby View Post
    Hey guys,

    Anything will help, thanks guys!!
    If you had bought the machine from a store then they would probably have no
    problem with sending a field service person to help you out at no charge. You can
    try calling a Miller dealer close to you and see if something can be worked out. Might
    not cost anything, might take 5-10 minutes. No offence to your abilities.
    These service guys drive all over the place trouble-shooting problems.
    Last edited by bluesky; 05-28-2015, 08:10 PM.

    Leave a comment:


  • Jay Gadsby
    replied
    Ok, here ya go. I am no Martin Scorsese, but it should represent thre issue I hope. Thank you guys for taking the time to help me out. Miller Spectrum 375 Cup Error: https://youtu.be/go6xfo474Y8

    Leave a comment:


  • Jay Gadsby
    replied
    As soon as the little one crashes i will grab some video.

    Leave a comment:


  • cruizer
    replied
    Maybe post a video on what it's doing, and the front panel as well

    Leave a comment:


  • Jay Gadsby
    replied
    Lol, well here is the number:LK260218PSoooo, board damage like "replace your board" or board damage like "replace relay RC1" or something. At this point I am ready to just drop 200 bux on cutting discs and call it a day. This is for pure hobby, not work. Thanks guys.

    Leave a comment:


  • H80N
    replied
    Originally posted by Jay Gadsby View Post
    Thanks for the quick reply. I double checked the consumables, they are in the correct order and are all brand new. The cup was not over tightened. DLed the manuals, it also says to just check the consumables. So very frustrating. I just want to cut steel lol. Air supply isnfine, running through a brand new filter. It is set on 110v through a 15 amp grounded outlet. Should I try a 230 setup? Would that make a difference? Hate to be a pain in the arse, but do appreciate help.
    Jay

    post your serial number.. and maybe "CRUIZER" will check in on your thread..

    he is a very experienced service tech who has helped many many posters...

    EDIT... still post your serial# and cross your fingers..
    Last edited by H80N; 04-17-2015, 04:41 PM.

    Leave a comment:


  • cruizer
    replied
    Board damage, unit has no open circuit voltage to start the pilot arc

    Leave a comment:


  • Jay Gadsby
    replied
    Thanks for the quick reply. I double checked the consumables, they are in the correct order and are all brand new. The cup was not over tightened. DLed the manuals, it also says to just check the consumables. So very frustrating. I just want to cut steel lol. Air supply isnfine, running through a brand new filter. It is set on 110v through a 15 amp grounded outlet. Should I try a 230 setup? Would that make a difference? Hate to be a pain in the arse, but do appreciate help.

    Leave a comment:


  • H80N
    replied
    Originally posted by Jay Gadsby View Post
    Hey guys,

    I was given a Spectrum 375 by a friend because he had another setup and this one needed a torch. Bought a new XT30C torch, installed only to get a flashing cup error when the trigger is pulled. Air flows, but no Arc. The wires for the 4 pin connector had to be moved around according to Miller tech. The orange wire had to be jumped to the empty pin below it. Same cup error. Still getting air. Pulled out the circuit board, cleaned everything up, very gently. Reinstalled, same issue. Tech says it may be the board itself. There are no burn marks, no ozone smell, etc. Can someone please point me in the right direction for trouble shooting. If in had the money to drop on a new board, I could just buy a new machine . Anything will help, thanks guys!!
    Check that the consumables are installed in the torch correctly.. if wrong you will get such an error...

    Also.. here is the link to the manuals... just plug in your Serial number for the correct version..

    http://www.millerwelds.com/service/ownersmanuals.php

    Leave a comment:


  • Jay Gadsby
    started a topic **Need some help** Spectrum 375 w/XT30C torch

    **Need some help** Spectrum 375 w/XT30C torch

    Hey guys,

    I was given a Spectrum 375 by a friend because he had another setup and this one needed a torch. Bought a new XT30C torch, installed only to get a flashing cup error when the trigger is pulled. Air flows, but no Arc. The wires for the 4 pin connector had to be moved around according to Miller tech. The orange wire had to be jumped to the empty pin below it. Same cup error. Still getting air. Pulled out the circuit board, cleaned everything up, very gently. Reinstalled, same issue. Tech says it may be the board itself. There are no burn marks, no ozone smell, etc. Can someone please point me in the right direction for trouble shooting. If in had the money to drop on a new board, I could just buy a new machine . Anything will help, thanks guys!!
Working...
X