Announcement

Collapse
No announcement yet.

Dynasty 300 dx problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    where can I find a new board?

    Comment


    • #17
      Now, you did do a reset on the unit, correct.... Unlikely to be the problem but you never know...

      Comment


      • #18
        No, I didnt do a reset how do I do that?

        Comment


        • #19
          You look in your owners manual under reset.........

          Comment


          • #20
            OK, if I do a reset and still doesn't work, where can I find a new board?

            Comment


            • #21
              I set the machine on stick and it works fine, just doesn't work on Tig.

              Comment


              • #22
                Have you tried scatch starting in tig, or lift arc??

                Comment


                • #23
                  No I havnt tried that. The machine is at my dads house he looking at it metering all the boards.

                  Comment


                  • #24
                    Originally posted by ktm505sx View Post
                    No I havnt tried that. The machine is at my dads house he looking at it metering all the boards.
                    He'll likely do more damage that anything good, unless he has a anti-static mat and a tracker. Metering out the boards is simply a bad thing, without the correct tools, and schematics.


                    If you don't try the basic stuff I tell you to do, all the diagnostics in the world will not help. I've been repairing all sorts of machines for the last 23 years, and have warranty status for every brand. $$$Factory courses galour.
                    Last edited by cruizer; 02-05-2015, 02:01 PM.

                    Comment


                    • #25
                      I haven't got to try the tig on lift arc yet but I will on Sat. If the tig will work on lift arc what could it be then and then what if it doesn't what could be the problem?

                      Comment


                      • #26
                        welder works on stick mode but nothing else. nothing on lift arc either. Cruizer what could be the problem

                        Comment


                        • #27
                          PC-3 is trashed

                          Comment


                          • #28
                            Well I had the machine looked at by a professional and they wanted to charge me $1200 to fix this board or get a new one, is that right?

                            Do you know of anywhere that I can get a new board?

                            Comment


                            • #29
                              ???????????????????

                              Comment


                              • #30
                                So I'm done, Whats with the question marks? I told you what was wrong from the beginning, up to you to find a board...

                                Comment

                                Working...
                                X