Announcement

Collapse
No announcement yet.

Dynasty 300 dx problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Dynasty 300 dx problem

    Ok, so the machine turns on goes through its cycle fine. I press the pedal, no arc, with help code 12. I really need this welder to work, it hasn't been used for 5 yrs because of the problem, so I finally decided to work on it. really need it so I can start fabricating again.

  • #2
    Its a front panels issue, so likely a stuck membrane button. Soak the front panel with tire foam, and press all the buttons. Might not feel a click, but they should all be able to press in, and come out easily. Armorall is useless, as is pretty much anything else.

    Comment


    • #3
      I can select different settings on the front panel but still no arc. when I press the foot pedal I don't get a error code but with the pedal press down and press a button the screen I get a help 12.

      Comment


      • #4
        Try it without the foot pedal. as hlp 12 means improper procedure

        Comment


        • #5
          I don't get a code when the pedal isn't pressed

          Comment


          • #6
            I turned the machine on, No codes, I pressed the pedal, the volt setting stays on the screen for about maybe 5-8 seconds and then it goes into its cycle down mode the I get a help 10 but while the pedal is pressed I get a help 12. Still no arc.

            Im still thinking its a board problem because of not having any arc.

            Comment


            • #7
              Still makes it a PC3 (display board) issue. Did you disconnect the remote and either lift start or stick weld with it??

              Comment


              • #8
                How would the display board be the reason im not getting a arc?

                Comment


                • #9
                  Originally posted by ktm505sx View Post
                  How would the display board be the reason im not getting a arc?
                  Simple, PC3 houses the programming and contactor controls.

                  Comment


                  • #10
                    Which board is the Pc3 board on the 300 dx Dynasty?

                    If you say it could be the board ill try to get it repaired.

                    with this board messed up the machine shouldn't do anything correct?

                    Comment


                    • #11
                      Originally posted by ktm505sx View Post
                      Which board is the Pc3 board on the 300 dx Dynasty?

                      If you say it could be the board ill try to get it repaired.

                      with this board messed up the machine shouldn't do anything correct?
                      Yep, Correct....

                      Front display board is pc3, tough to check, but other boards have specific error codes, easy to identify the problems. pC3 does not, which leads me to think that it's the culprit in this case.

                      Comment


                      • #12
                        Which board is that though, is it the one with the ribbon cable going to it?

                        When that ribbon cable isn't hooked theres nothing on the display.

                        Comment


                        • #13
                          My Dynasty 300dx was in the shop one time years ago when still in warranty for a bad board and never an issue since. Love this welder. Since we are working on this model and they are a few years old now, is there any good maint. advice to keeping them healthy. I did pick up on Cruizer's advise in another thread about letting them run and warm up for a while if it has not been used in some time. Anything else.
                          Last edited by Doug Doty; 01-25-2015, 09:20 PM.
                          Miller Dynasty 300 DX TR, 2007
                          Miller MM 251 w/30A spool gun, 2005
                          Lincoln SP-100, 1990
                          Hypertherm PM 45, 2014
                          Scotchman 5014CM Ironworker 2005
                          Grizzly 12x36 lathe 2010
                          Wilton Belt sander and Cutoff Bandsaw 2006

                          Comment


                          • #14
                            when this machine quit working on me I was welding with it and all of a sudden it just stopped working. the machine turns on it just doesn't do anything. no arc, nothing. I press the pedal it shows the amps and then it goes into the timing down mode then the help 12 comes up on the screen.

                            Is the pc3 the board that displays the amps and volts with all the buttons for the settings?
                            Last edited by ktm505sx; 01-25-2015, 09:44 PM.

                            Comment


                            • #15
                              OK, I've mentioned this a few times, PC3 yes has a ribbon cable going to it, as well as, 2 smaller thermister cables and the control for the front amphenol. This board handles the programming AND ARC CONTROL. NO ARC AND NO OTHER MEANINGFULL ERROR CODES ITS THE FRONT DISPLAY BOARD

                              Best to find a NEW board, unlikely that it can be repaired, due to possibly a programming glitch, or possibly just a failed zener. Tough to tell

                              Comment

                              Working...
                              X