No announcement yet.

Maxtron 450 cc / cv with 22A feeder

  • Filter
  • Time
  • Show
Clear All
new posts

  • Maxtron 450 cc / cv with 22A feeder

    I have a Maxtron 450, originally hooked up with a 60M wire feeder through the 14 pin and 17 pin output of the Maxtron, there is a Y using 14 pin and 17 pin on maxtron and converting it to a 14 pin that the 60 M is plugged in to. No problems whatsoever with that setup, I can use the feeder and regulate voltage and everything from the feeder.
    We just bought a new feeder, a 22A with voltage control, but when hooked up to the Maxtron, the voltage can't be regulated from the 22A like it was with the 60M, using the Y cable, I tried to plug it straight in to the 14 pin without going through the Y, and still not working.
    On the Maxtron itself, when everything is setup for MIG, the voltage can't be setup and yes the switches are in the right position, No problems regulating the Amperage for stick, but Voltage display will not display the actual voltage .
    I can do without being able to setup the voltage on the Maxtron, but my biggest problem is why would the 60M feeder work and not the 22A to regulate the voltage?
    My way of thinking is that the Y cable being used with the 60M rerouted the pins from the 14 and 17 pin on the maxtron to a location needed for the 60M, and Maybe the pin locations needed for the 22A are in different location in the plug and I would need another kind of Y cable in order to get the 22A to work?
    I also tried the 22A on a newer power source using only the 14 pin, and the feeder works good, so it's not a feeded problem, it's a compatibility between new feeder and old Maxtron somehow.