Announcement

Collapse
No announcement yet.

Synchrowave 250 problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Scot1966
    replied
    Originally posted by cruizer View Post
    Well, that machine is using a amp shunt to tell the board the amperage, not a hall like the later versions. pretty much reliable. so guessing that there is board damage. However, you can send the board in for repair as schematics are available

    its a 122-272, any circuit boar rebuilder will easily fix this board.
    Thanks cruizer

    Leave a comment:


  • cruizer
    replied
    Well, that machine is using a amp shunt to tell the board the amperage, not a hall like the later versions. pretty much reliable. so guessing that there is board damage. However, you can send the board in for repair as schematics are available

    its a 122-272, any circuit boar rebuilder will easily fix this board.
    Last edited by cruizer; 12-28-2014, 05:02 PM.

    Leave a comment:


  • Scot1966
    replied
    Originally posted by cruizer View Post
    If the unit goes full blast 99%of the time its a failed hall device (lem), it's separate from the control board.
    I have been looking around for a hall device on different parts supplier websites, and am not having any luck finding it. Are they expensive ? Is it probable enough that I should take the chance and replace it ? Also, where is the best place to buy it ?

    Leave a comment:


  • cruizer
    replied
    If the unit goes full blast 99%of the time its a failed hall device (lem), it's separate from the control board.

    Leave a comment:


  • Sberry
    replied
    I have a schematic for my 300, a 50 cent transistor on the board was a problem and my TV repairman bud fixed it.

    Leave a comment:


  • Scot1966
    replied
    Originally posted by gawelder View Post
    I've got a syncrowave 250 with the same problem several people from Miller have told me the circuit board is the problem.

    Did they hey give you a price for a new board ?

    I'm wondering where the best place is to buy a board. I know I've heard some people use re-manufactured boards... They replace whatever is bad in them and test them before selling the board.

    Leave a comment:


  • Scot1966
    replied
    Originally posted by walker View Post
    Have you tried disconnecting the remote and stick welding?
    I have not tried stick welding, only switching remote to panel and TIG welding...same results.

    Leave a comment:


  • walker
    replied
    Have you tried disconnecting the remote and stick welding?

    Leave a comment:


  • gawelder
    replied
    I've got a syncrowave 250 with the same problem several people from Miller have told me the circuit board is the problem.

    Leave a comment:


  • Scot1966
    started a topic Synchrowave 250 problem

    Synchrowave 250 problem

    Hello everyone,
    I am new to this forum and have a question I hope someone can help me with. I have a Syncrowave 250 serial # JK618511. I bought it from a co-worker in the 90's and it has been trouble free (until today). It is kept in my dry basement, and is rarely used. This morning I went to weld something and it comes on at full power no matter where the pedal is. I tried switching to panel with the amps set at 10 and it still comes on hot...so hot it melts the 3/32" tungsten. AC is the same. What are the chances that this is a bad board ? If so, do you think I should take the chances of replacing it myself and hoping it works, or should I call a tech in case it's not the board. I know they are not returnable, and would hate to be out the $ for a board if that's not it.
    Any help is appreciated !

    Thanks, Scot
Working...
X