Announcement

Collapse
No announcement yet.

Miller 250 Trail Blazer drops voltage while welding stick

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can You Weld This For Me?
    replied
    Have you pulled the brushes out of the holders and looked at them? I have seen the caps on back end of the springs be crusty and not making good contact also.

    Leave a comment:


  • Dishtech43
    replied
    Originally posted by cruizer View Post
    A rectifier just doesn't work then not work, either does a board, unless its cracked in a certain way. I suggested cleaning your slip rings in a couple posts above. Maybe try that....
    That makes since...Ill try it in next day or two.. Thanks for your info...Saved my alot of money just trying thing..

    Leave a comment:


  • cruizer
    replied
    A rectifier just doesn't work then not work, either does a board, unless its cracked in a certain way. I suggested cleaning your slip rings in a couple posts above. Maybe try that....

    Leave a comment:


  • Dishtech43
    replied
    Originally posted by cruizer View Post
    Yeah, but if any kind of varnish on the rotor tends to liquify (when the rotor gets hot) and make the brushes stick, thus you loose power. If the sliprings look kinda wavey and blackish, there is a film of oil on them. Took a while to figure this out while working on some troublesome machines, as the brushes looked just fine. Simple to test anyways.
    What would you recommend me to do? Ill try anything to get it fixed.be alot cheaper to check brushes than to buy a Rectifier...how can I test.and how to clean..brake cleaner maybe..? thanks

    Leave a comment:


  • cruizer
    replied
    Yeah, but if any kind of varnish on the rotor tends to liquify (when the rotor gets hot) and make the brushes stick, thus you loose power. If the sliprings look kinda wavey and blackish, there is a film of oil on them. Took a while to figure this out while working on some troublesome machines, as the brushes looked just fine. Simple to test anyways.

    Leave a comment:


  • Dishtech43
    replied
    Originally posted by cruizer View Post
    Maybe brushes are worn and sticking...... Brakeclean and a fine emory work for those, or just replace them
    They seem to move up and down just fine..that was the first thing I thought of..This thing is driving me crazy ..LOL

    Leave a comment:


  • cruizer
    replied
    Maybe brushes are worn and sticking......

    Brakeclean and a fine emory work for those, or just replace them

    Leave a comment:


  • Miller 250 Trail Blazer drops voltage while welding stick

    I bought a use Miller 250 Trail Blazer a couple years ago..and have a problem . When welding stick.Ill be welding along ,and all of a sudden it drops voltage and stops welding.It just has a light spark..I the turn it up to higher settings.and weld for a while.and then it kicks into high voltage..melting my welding .TO Hot...It does this back and forth..I just parked it last year.but I want to fix it..and ideals..maybe rectifier?? It has a gas 20 hp motor..nice shape welder..thanks guys in advance..
Working...
X