Announcement

Collapse
No announcement yet.

Another busted Trailblazer 251 with only 290 hours! Anybody have bad PC2 boards?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by Can You Weld This For Me? View Post
    Just want to triple confirm, you do have the output contractor switch "ON" correct?
    Both switches are in the up position.
    Millermatic 200
    Miller TB 251
    Miller roughneck
    WC-24
    Spoolmatic 30A

    Comment


    • #17

      Originally posted by denwhit View Post
      I hope mine turns out to be that easy (cheap fix). What reading, voltage or resistance, showed the problem?
      While while testing, I bumped a wire and it sparked. Just pull apart your molex connectors to check for corrosion, and loose ones will make themselves apparent.

      Comment


      • #18
        Originally posted by walker View Post



        While while testing, I bumped a wire and it sparked. Just pull apart your molex connectors to check for corrosion, and loose ones will make themselves apparent.
        thanks for that
        Millermatic 200
        Miller TB 251
        Miller roughneck
        WC-24
        Spoolmatic 30A

        Comment


        • #19
          Fixed it!

          After getting good ohm readings across the diodes in the bridge rectifiers, yet getting screwy voltage readings, I just decided to replace them both. That worked! She's back to performing like a new one. I guess the lesson is that when the actual current hits those rectifiers, the real test begins. Anyway, my thanks to everyone who participated with help and advice.
          Millermatic 200
          Miller TB 251
          Miller roughneck
          WC-24
          Spoolmatic 30A

          Comment

          Working...
          X