No announcement yet.

301G Trailblazer not welding

  • Filter
  • Time
  • Show
Clear All
new posts

  • 301G Trailblazer not welding

    Hello everyone, I just bought a used 301g trailblazer and used it once for about 5 minutes letting my 7 year old try to weld with some 3/32. It worked well. I tried using it about two weeks later and it has 0 output. It has about 400hrs on it and already had a pcb2 put in it at 350 hrs. both pcb1 and pcb2 look fine but I am not sure what it would be. If anyone could tell me what to look for or what it might be that would be great. I am not to familiar with this kind of stuff. It has not been boosted at all. It is in an enclosed trailer and in between the 2 weeks I didn't use it, I puled the trailer to the scales to get a weight but the road was pretty smooth.

  • #2
    Just a guess, but perhaps 1 of your brushes is stuck, and/or really dirty slip rings.

    I soak a piece of emory fine grit with brake clean and swish back and forth on each slip ring to clear the crap off while running.


    • #3
      Click image for larger version

Name:	image.jpg
Views:	1
Size:	62.3 KB
ID:	516664Thanks for your suggestion, I cleaned the rings and made sure the brushes were not stuck and I still have no output. I do have ac power but no dc. I am going to try to post pics of pcb1 and 2 to see if anyone can see something I am missing


      • #4
        And the front panels selector switch is in the up (live) position?


        • #5
          Yes it is.


          • #6
            tough one to call, best take it in. something to do with the power board though, what does the display say for volts