No announcement yet.

Miller 301g will not strike a arch.

  • Filter
  • Time
  • Show
Clear All
new posts

  • Miller 301g will not strike a arch.

    Hello to all. I have a miller 301 g welder that is about 13years old . I take good care of it and have only used it a couple of times. It has 150 hrs on it. Yesterday I was getting ready to weld some cracks in a dump truck tail gate and it wouldn't strike a arch. After checking ground and still nothing I tried striking a arch on the ground clamp. Still no arch. I checked setting on machine and everything looked good. I switched the polarity lever to a/c and to electrode negative and then back to electrode positive a few times and it started welding fine. Thought maybe just had connection. Oh well. I weld for about 2.5 hours and shut machine down. Today I get home and start machine up and again it will not start a arch. I worked every lever on it back and forth and still nothing. I removed covers and checked fuses , looked at the front and back side of the chip boards and no burnt spots and blown fuses. Searched internet and cleaned the rings the brushes ride on with a wet rock. They were a little black and glazed. Still no arch. Checked and welder is producing power to a/c plugs. 120v and 240v. Grinder runs fines when I plugged it in.searched some more on internet and checked remote adjust switch to make sure it wasn't switched to remote. Still no arch. I turned the amp adjust dail to high and it will try to weld but it isn't producing enough power. Engine runs great . Idles up when you try to start a arch but just no arch unless you have dial turned all the way up. does anyone have any suggestions are things I could check. I appreciate all y'all's help. Thanks in advance.