No announcement yet.

xmt 300 problems

  • Filter
  • Time
  • Show
Clear All
new posts

  • xmt 300 problems

    I have an xmt 300 ( ka828890) that has no welding output. I took some time and did some searches on here to learn about the more common problems with these units before starting my own thread. I didn't find any post that exactly matched my case but i did learn about some things to check. my symptoms are

    no output at the front of the machine regardless of where the switches are or whether or not pins A and B are jumpered on the 14 pin remote

    Display displays -1 on the left side and does not change. it is dim on the right

    Checked input voltage 245 and machine is properly (according to manual) configured for 220

    The contactor switches five seconds after turning on and buzzes thereafter

    I checked dc voltage on the output side of the sr1 and it was 330v

    I did not see any obvious damage to the IGBTs or anything else for that matter

    thanks for the help

  • #2
    Corroded connectors on the control board ( pull and reinsert all of them, power off)

    Control board damage ( no you likely won't see it) or failed thermal on the output rectifier


    • #3
      Thanks Cruiser, i tried pulling and replugging the connectors today. no change

      Would you please explain how to check the thermals on the output rectifier?

      Is there a place you would recommend that i send my board to have it checked out? Thanks again.


      • #4
        control board damage

        I found something, a component labeled u2 on the pc1 control board looks like it got hot. I couldn't see it until i got the board out and looked at the back of it.

        My next question is what causes this? I don't want to just have the board fixed without addressing an underlying problem that caused it to heat up. Or maybe the board just fails and that is the end of it.

        I follow the procedure in the manual about checking for voltage at the sr1 before working on the machine. I was surprised to still find 120 v there, even though i left it unplugged for a couple days. is this normal?


        • #5
          still the same

          well i got my reconditioned board back today. I installed it and there is still a -1 on the display and no welding output. I' am still hoping someone might explain how to check those thermals as that mentioned as a possible cause.


          • #6
            Well, the programming on this unit is on the control board, the contactor control is on the display board. Perhaps there is where the problem lies/ Tough call as the 300's were full of dead end circuitry. I'd almost say to take it in for a looksee. But that will likely only get you in deeper financially, as few techs really know this machine.


            • #7
              That is what i was afraid of. Is there a way to get the service manual for this machine? I called miller and they won't sell me one because i' am not a tech.


              • #8
                Originally posted by junkman View Post
                That is what i was afraid of. Is there a way to get the service manual for this machine? I called miller and they won't sell me one because i' am not a tech.
                A tech manual won't help much if your not a trained tech. Give up now, I don't even bother with them they come in, I tell the customer that I can't be bothered with it and into the trash it goes.


                • #9
                  Check the voltage on your cap banks and see where they are. You could possibly have a cap that is shorted open. If caps look good then check out both IGBT's with a diode test. Also check the diodes on both rectifiers. If that doesn't find your problem then, like cruizer said, toss it.