No announcement yet.

Syncrowave 180SD

  • Filter
  • Time
  • Show
Clear All
new posts

  • Syncrowave 180SD

    Hello, I have the above machine that I bought new back in the late 90's to do small stainless repairs. It paid itself off in that regard but sits mostly and I would imagine that it has maybe 10-20 hours on it. Anyway, I've had the problem before where there is no current control, it just goes full bore in either TIG or stick. I was recommended to check the Hall effect sensor at that time and indeed that was the problem, maybe so corrosion on the connections. I unplugged and replugged the connector at the sensor and it worked. That was a couple of years ago, I am having the same issue and have repeated the process which worked a couple of times but after the 3rd time, it's not having an effect. I even unplugged and re-plugged all the connectors to the board (RC1-4) with no result.

    I can certainly get some dielectic which is not a bad idea regardless, but does it sound as if the Hall effect sensor is bad? Seems odd that it would fail with the minimal use but maybe age is the culprit. Also, from other threads, it sounds as if when they go, they go, no intermittant behavior. Is there a way to test one? I have also read on other threads (thank you) where to purchase a replacement for a reasonable price.

    thoughts would be appreciated. Thanks