Announcement

Collapse
No announcement yet.

Dynasty 300 questions

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ASKANDY
    replied
    10-4 Bug

    Leave a comment:


  • BugEyedValiant
    replied
    The strong cleaning action requires a MONSTER tungsten because the majority of the heat is concentrated on the electrode tip. It takes a 1/4" tungsten to run 125 amps, and a 3/32" tungsten can only take a max of about 30 amps. As Andy says it isnt even worth trying. To me the only time that you should use EP is when you need to weld thin aluminum and you only have a DC powersource.

    Leave a comment:


  • zx1200r
    replied
    My welding text book states that DCEP tig has a stronger cleaning action then DCEN, so I wanted to see if it made a difference.

    Leave a comment:


  • ASKANDY
    replied
    Why would you do that?

    TIG steels should be done in EN

    Leave a comment:


  • zx1200r
    replied
    How do I change the default tig setting to DCEP + ?

    Leave a comment:


  • ASKANDY
    replied
    Sounds like some sort of contamination. If the machine welds fine on Alum, it will easily do steel. The flow rate would depend on the cup size but you are close on average. You should not have to change any cables! The machine changes polarity of the electrode for the proper processes. All you need to do is tell it TIG or Stick and the Dynasty does the rest. While in TIG steel, the machine will default to EN. Stick default is EP. Make sure you are still using 100% Argon gas for steel too. I know a few people who switch gas to a 75/25 Arg/Co2 because that is what their MIG welder uses for steel. TIG uses 100% Argon for all metals.

    Hope this helps.

    Andy

    Leave a comment:


  • zx1200r
    started a topic Dynasty 300 questions

    Dynasty 300 questions

    I have a Dynasty 300 with the coolmate package, its been working good so far with aluminum.
    1.I have some mild steel around 3/32 that I was welding with a 3/32 2% thoriated tungsten on DC and it is hard to keep it going, the metal seems to crater and leaves a lot of holes in the weld. I wire brushed the metal to clean it. What could be the problem?
    2.What is a good flow rate for argon, I use around 15-20, and at what pressure should the tank be refilled?
    3.How do I change between tig DCEN and DCEP, and stick DCEN and DCEP? The owners manual says not to switch the ground and the torch cables.
Working...
X