Announcement

Collapse
No announcement yet.

pipepro 304 help

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • pipepro 304 help

    I have an 08 pipepro 304, it just came from the shop where I spent $5000 putting a new inverter in it. Now it won't idle up with a grinder and won't idle up with big rod like it should. I called the shop where it was fixed and they aren't any help and I'm 1100 miles from them so I can't just take it back.
    sigpic2007 dodge 3500 cummins

  • #2
    Maybe shoot me the serial# so we are on the same page.

    And thats a pretty hefty price as its basically a standard xmt 304 with a couple extra boards in the back. What happened to the original as there is not much too them, least not $5k worth.

    Never the less check your circuit breakers, there are 3 in a row center frame ahead of the air cleaner. I think its the 3rd one in from the left

    Comment


    • #3
      The idle started workin right today, but now there's another problem. I got a cordless remote for it and now whenever I weld it sounds like it has a pulser. The higher the amps the faster the pulsing noise. I turn it back to panel and the noise goes away. It welds the same both ways but the noise is worrying me.
      sigpic2007 dodge 3500 cummins

      Comment


      • #4
        Time to change your batterys

        Comment


        • #5
          Originally posted by cruizer View Post
          Time to change your batterys
          In the remote? Or the machine
          sigpic2007 dodge 3500 cummins

          Comment


          • #6
            In the Remote and the reciever. Even if the remote is new, you don't know how long it sat there. I toss the new batterys right away in favour of some better quality versions.

            Comment

            Working...
            X