Announcement

Collapse
No announcement yet.

Miller 375 Xtreme with Ice Torch

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ShockHazard
    replied
    Originally posted by cruizer View Post
    If your using the shield cup on the torch, it's supposed to be on the work surface, if not 1/16" is good. also have the torch at an angle to blow the dross away. While the unit adjusts air pressure, you should have at least 90 psi going to it.
    Unit uses alotta air, so the air line must be a minimum of 3/8"
    Cruizer is right on about the air pressure with your compressor. Many people here use the "motorguard" filter. I too think it's crap. What I did was I bought a $30.00 filter/water seperator from Home Depot. That filter is connected close to the output of my DeWalt air compressor. Closer to the cutter itself, I installed the "Miller" in-line air filter. Basically I have two filters connected and it works great. The Home Depot filter really draws out moisture from the compressor. I'm really impressed.

    Are there better filters? Yes, absolutely. Do I want to spend that kind of money on them? **** no. I've spent enough as it is with the machine itself and all of the other tools in my garage shop. The plasma cutter itself doesn't need any filters, albeit the consumables will wear out faster without a filter. I figured that the standard Home Depot air compressor/seperator filter is good enough. I've been using the two combined filters now for almost two years. So far, so good. I don't go through consumables hardly at all and I've cut a ton of steel, stainless and aluminum.

    ....and to the OP, yes a good ground connection is very important. The distance between the ground connection and the actual cut is should always be as short a distance as possible too.

    Leave a comment:


  • TucsonPlasma
    replied
    Originally posted by cruizer View Post
    OH and the motorguard filters or toilet paper type filters are crap, best use an over size hurricane filter and leave the drain open slightly then forget about it.
    Ok thanks, i kind of figured out. The metal i was cutting has a lot mill scale and oil on it. Once I grinded it down and put the ground on it, it cut a lot better. Something as simple as that made all the difference. That isnt in any forum anywhere. Go figure.
    thanks for your responses.

    Leave a comment:


  • cruizer
    replied
    OH and the motorguard filters or toilet paper type filters are crap, best use an over size hurricane filter and leave the drain open slightly then forget about it.

    Leave a comment:


  • cruizer
    replied
    If your using the shield cup on the torch, it's supposed to be on the work surface, if not 1/16" is good. also have the torch at an angle to blow the dross away. While the unit adjusts air pressure, you should have at least 90 psi going to it.
    Unit uses alotta air, so the air line must be a minimum of 3/8"

    Leave a comment:


  • TucsonPlasma
    replied
    Anyone?
    What should the standoff be on the 27T torch? Would the Swirl Ring cause cutting issues? Is there a way to test the torch to see if is indeed putting out 27amp?
    Any help would be appreciated.

    Leave a comment:


  • TucsonPlasma
    started a topic Miller 375 Xtreme with Ice Torch

    Miller 375 Xtreme with Ice Torch

    Hi all,
    This is my first post here.
    I just bought a used 375 Xtreme with the old ICE torch 27amp. I tried it out and have some questions for owners of this model. I have a 30 gallon compressor with a motorguard filter and water trap, new consumable on the torch and a standoff roller.
    My question is...I tried cutting 3/16 plate and it struggles quite a bit. My Travel speed is slow but if I go any faster it starts blowing sparks out the front side. I have it at 27amps and hooked up to a 220 volts. The standoff is 1/16". There is a lot of dross on the back side that is easily knock off. Is this normal? I thought that it was rated to 3/8" It should be blowing right through the 3/16"? Can someone give me some tips on what might be causing the lack of power?
Working...
X