No announcement yet.

no amp control... econotig..

  • Filter
  • Time
  • Show
Clear All
new posts

  • #46
    Any Word???


    • #47
      I'll be glad to look at some bad boards if anyone has them. I'm pretty good at reverse engineering stuff and have the tools to do it.
      Dr. Bill UNC Charlotte


      • #48
        3 years later... really??

        Haha, finally got some free time this christmas to relook at it. I came across this old thread! It seems like this is still a common problem so I'll resurrect it and hopefully have a good outcome in the end.

        I did find a newer econotig on ebay for dirt cheap and have been using that for my odd jobs since then... been a little weary to post the board from the working into the old one just in case it's a little on the hardware side.

        Anyways, I have replaced just about every component on the board with no avail but I'm going to try the rest of the components and hopefully find the solution.

        The biggest problem I'm having is the board from this machine (KF788280-1995) is outdated and the newest service manual (TM-303J) is from 2008. Since then the board changed so that now the remote is regulated by the knob on the machine. The old board (mine) just gives full access to the range of current.

        So there isn't a direct relationship between the two. I am currently going to school for electrical engineering but don't really know enough to make the relationship with a 100% certainty. The price of a new board ($450) is keeping me motivated though!

        I said it before and forgot but I will continue to try to keep this post updated for those that get answers from the internet like me (the internet keep info for a long time and who really looks at the post dates anyways.. )


        • #49
          A silly scope won't help much, really all you need is a Huntron tracker. You can test components in circuit and graphically analyze them.


          • #50
            Sounded good so I googled. The tracker is for smaller current ratings (60v @ .6mA) and the cost is a little too high for now. The board has a few components that are over this rating (thyristor and the IGBT) and might need to operate over the trackers range, but I'm not 100%.

            I've posted the working board into the older machine and it works great so I know the board is bad. I tried looking at 3E services and they quoted me $275 to fix the board.

            It's a $70 testing fee if they take a day or two to figure it out and then the rest if they can fix it. I'm thinking about it but need to wait until I have the money to choose it.

            I wish I could find the older service manual though. That would make trouble shooting a little more straight forward. I will probably have to wait till this semester is over though to get back into it though.


            • #51
              Originally posted by buk View Post



              ^^ this guy apparently fixed his problem..

              im trying to contact the person i bought it from but i doubt ill get any help from him..

              I tried to register with 'DTSFAB' but I couldn't finger out what the 'R' in FNR means. Meanwhile, I still have no amperage control. I'll read on.


              • #52
                NewBe - second post

                I've had my EconoTIG since the late eighty's. Last month I lost amperage control just as described here previously. I guess it's the motherboard. I've read on another forum how someone made some changes to allow him to run the foot control by switching to stick and wiring the foot control pot in place of the stick amperage control pot on the front panel but now I can't find the link. I guess I can still TIG if I can figure out how to get the argon valve and the HF to switch on and off.

                Any ideas?


                • #53
                  I haven't heard of the switch you're talking about (changing the pot over for the foot control) but honestly I'm ready to get this thing out of the garage. I have an older econotwin(78?) that works great and doesn't use a board for controlling amperage(an old turn crank) and two of the later 80~90 models.

                  I am ready to spend the money on a new board and just sell two of the units on craigslist to get the space back. Prob not what you want to here but I'll post the websites of the place that sells old boards for cheaper than new ones (prob has a limited warrenty) and the guys that repair(not sure if the price will be the same still) when I get them.


                  • #54
                    I am having this exact control over amperage regardless of foot pedal position.replaced supressors 1 and 2 along with the rectifier at q13 with genuine miller parts and nothing.i have a very expensive paperweight.any suggestions?


                    • #55
                      Did you go thru the troubleshooting procedures today I posted in your thread?
                      MM200 w/spot controller and Spoolmatic 1
                      Syncrowave 180 SD
                      Bobcat 225G Plus LPG/NG w/14-pin*
                      *Homemade Suitcase Wire Feeder
                      *WC-1S & Spoolmatic 1
                      PakMaster 100XL
                      Marquette "Star Jet" 21-110


                      • #56
                        if anyone read this thread to find an answer to the econotig board prob. Here's the end to my efforts - Paid Innovat Corp 265+13ship to fix the board and send back. Works great but here's the kicker - they didn't replace a single danm component on the board. Every single solder was the same as I left it!

                        It must have been the pots, I think of it like the low/high idle jets on a carb, maybe they have to be set just right to get it on point... Oh well at least it works now and I can sell it off and make the room in my garage! ))


                        • #57
                          Thanks for the follow-up!