Announcement

Collapse
No announcement yet.

Sync 350 problem?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Sync 350 problem?

    This weekend I was at a local collage for a welding competition and we used sync 350's for the Tig portion. We had a foot pedal and for some reason no matter what I did I could not control the amperage with it, everyone else was having the same problem. It was an older Sync 350 early 2000's model I think? Could it be that the pedal could not control the amperage even though it was set to remote due to it being an older unit?
    Saving for Dynasty 200 DX

  • #2
    I had the same problem on time on a Sync machine, and it was the connection between the pedal and the machine that was bad. Wiggled it some and it started working again.

    Tobin
    MM251
    Miller Dialarc HF-P 310 Amp Tig
    Victor O/A Setup
    Lincolin 225Amp Buzzbox
    Cummins Freak

    Comment


    • #3
      Most likely a broken wire in the foot pedal. It could also be at the connector or in the cable itself. If it is the cable the damage should be visible.
      Dennis


      Thermal Arc 185-TSW
      Millermatic Challenger 172
      VictorO/A
      Atlas Craftsman 12 by 24 Lathe
      Esab PCM-875
      Wholesale Tool Mill-Drill

      Comment


      • #4
        I had this problem last year. Was a loose wire to the potentiometer in the foot pedal. Simple fix.

        Comment


        • #5
          A friend of mine that was there with me asked one of his dads friends that's a Tig welder and he said the same thing. Thanks for helping. looks like they need to replace the pedal.
          Saving for Dynasty 200 DX

          Comment

          Working...
          X