Announcement

Collapse
No announcement yet.

Dynasty 200DX, reduced cleaning

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • LightningStruck
    replied
    That'd be the one....(Louis is actually Lou's kid)

    Louis is the guy that really got me talked into getting my Dynasty.. I don't take his advice lightly

    Leave a comment:


  • Laiky
    replied
    Originally posted by Louis View Post
    Yessir! Tell Mitch Wright Louis Gigliotti says Hello
    Of LG Motorsports Fame??

    Leave a comment:


  • Louis
    replied
    Yessir! Tell Mitch Wright Louis Gigliotti says Hello

    Leave a comment:


  • dkizerian
    replied
    Louis - Love the WC car!

    Miller Motorsports Park (not affiliated with the welders) is my local track, and I'm the Utah SCCA road Race Coordinator. Will you be coming out in May?

    Leave a comment:


  • Louis
    replied
    Tri Gas came and picked up the faulty cylinder today, Ill reply back with what they find. Over all, the machine is welding fine now, so only time will tell.

    Thing that gets me is, how can one machine be affected by gas, and the other one is not?

    Leave a comment:


  • Louis
    replied
    Back for good Curt

    Leave a comment:


  • tigman250
    replied
    Originally posted by Louis View Post
    Little update- Welder is doing much better, everything is fine- I swapped bottles from one that I had at home ( different source) and everything seems to be OK.

    I will swap back to the other bottles and see if it still welds bad.

    If it does not weld bad, it would lead me to believe that it is something that might be going wrong internally..... Intermittantly.

    I will update as the day progresses.

    Thanks again
    hopefully it is just bad Argon, that always ticks me off but at least it isn't the welder failing.

    Leave a comment:


  • LightningStruck
    replied
    So are you just down in Dallas for hte weekend Louis, or have you graduated?

    Leave a comment:


  • Louis
    replied
    Little update- Welder is doing much better, everything is fine- I swapped bottles from one that I had at home ( different source) and everything seems to be OK.

    I will swap back to the other bottles and see if it still welds bad.

    If it does not weld bad, it would lead me to believe that it is something that might be going wrong internally..... Intermittantly.

    I will update as the day progresses.

    Thanks again

    Leave a comment:


  • calweld
    replied
    Originally posted by Louis View Post
    If this one needs a 1200$ board replacment, Im NOT going to be a happy camper. Its JUST out of warranty....
    Back about 1990 or so, I had a Trailblazer that had a bad bearing plate at the end of the armature (bearing was spinning in the hole), two months out of warranty, Miller paid for the repair

    That car and frame look beautiful, nice work. Nice to see somebody occasionally that's actually involved in "motorsports" on this board . . .

    Leave a comment:


  • Louis
    replied
    I have a lot of fabrication to do today ( Sunday, lol) so Im going to use the good welder. I have parts that need to go on the car and guys sitting around waiting for them.

    When I get a spare chance, Ill swap everything over and see what I can dig up. The last time this machine was used on AC, it welded great. Last night I was trying to figure out the last piece of AL I welded, and that was a 1/4" thick 6061 computer case, and it did just fine. Beautiful actually...

    Here is a pic of the race car- 2006 C6 Z06, 500 hp, 2800 pounds, and a lot of down force. Check out www.world-challenge.com for the series and schedule info





    Chassis pic- started with a C5 corvette frame ( Steel vs Alum chassis on the C6Z) for safety and ease of rollcage implimentation. We have built 9 chassis' since 2004, all with the dynasty and Syncrowave




    Thanks

    Louis

    Leave a comment:


  • lramberson
    Guest replied
    Before you dump it over to the service center I would recommend a call to tech support and I would do it on Monday. If the Machine is just out of warrantee, and the issue you had before,(and being a Motorsports) I am sure that they will work with you. Service is Millers middle name, I hope you get the problem worked out.

    Leave a comment:


  • Louis
    replied
    Settings are 65 EN and 140 freq. on both machines. I have not tried different torches, yet.

    I tried all 3 bottles of pure argon I have here, 1.5% Lan, 2% thoriated, different filler, my neighbors filler, my dogs filler, acetone, 15CFH-50CFH, and nothing made a difference, until I drug out the machine that was tucked away.

    I have not welded any DC stuff lately, Ill run some beads tomorrow on DC. When the board went in the last one, it welded great in DC.....just couldnt run a bead in AC for the life of me, and Ive been welding since I was 9. This one, however, will run a bead, but its got NO cleaning, and very dirty welds.

    Will there be a lack of cleaning given poor gas, or impure argon/ect?

    Thanks for the replies, If I cant get it solved, Im going to send it to the local store that did the first board. I moved from Indy, so my local shop ( Sutton-Garton in indy) is no longer local for the shop machine.

    Louis

    Leave a comment:


  • LAN
    replied
    what about torches?- have you tried the bad machine with the torch from the good one? i know it's a long shot but if you have a leak/blocked gas line,...

    having said that, does it weld fine in DC? that would eliminate the gas leak theory- welded any stainless with it recently?[/QUOTE]

    +1 to that. Try both machines hooked up to the same gas, and use the same gas leads try the same torch on each machine, and make sure that the balance is set exact on each machine and not to much EN(somewhere between 60-70% EN). Good luck man. Let us know what happens.

    Brad

    Leave a comment:


  • Peter
    replied
    hey all,

    agreed, the virtual lack of an etched zone suggests that the balance is wrong but,...
    Originally posted by Louis View Post
    Im going to attach a pic of the same filler, SAME settings, SAME GAS, and same welder (me ) but 2 different machines.
    that takes care of most of the usual suspects

    what about torches?- have you tried the bad machine with the torch from the good one? i know it's a long shot but if you have a leak/blocked gas line,...

    having said that, does it weld fine in DC? that would eliminate the gas leak theory- welded any stainless with it recently?

    Leave a comment:

Working...
X